# Logstash 8.1.0-1 fails to start

**URL:** https://discuss.elastic.co/t/logstash-8-1-0-1-fails-to-start/300059
**Category:** Logstash
**Created:** [March 18, 2022, 3:13pm UTC](https://discuss.elastic.co/t/logstash-8-1-0-1-fails-to-start/300059 "2022-03-18T15:13:12Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![lmalossi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lmalossi/32/14766_2.png) [@lmalossi](https://discuss.elastic.co/u/lmalossi)
#### Post date: [March 18, 2022, 3:13pm UTC](https://discuss.elastic.co/t/logstash-8-1-0-1-fails-to-start/300059/1 "2022-03-18T15:13:12Z")

</div>

Hi all,  
I'm trying to start logstash with systemctl but in log i get the following

```auto
[2022-03-18T16:07:32,888][INFO][logstash.runner] Log4j configuration path used is: /etc/logstash/log4j2.properties
[2022-03-18T16:07:32,895][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"8.1.0", "jruby.version"=>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.13+8 on 11.0.13+8 +indy +jit [linux-x86_64]"}
[2022-03-18T16:07:32,898][INFO][logstash.runner] JVM bootstrap flags: [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -Djruby.jit.threshold=0, -Djruby.regexp.interruptible=true, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, --add-opens=java.base/java.security=ALL-UNNAMED, --add-opens=java.base/java.io=ALL-UNNAMED, --add-opens=java.base/java.nio.channels=ALL-UNNAMED, --add-opens=java.base/sun.nio.ch=ALL-UNNAMED, --add-opens=java.management/sun.management=ALL-UNNAMED]
[2022-03-18T16:07:32,905][DEBUG][logstash.modules.scaffold] Found module {:module_name=>"fb_apache", :directory=>"/usr/share/logstash/modules/fb_apache/configuration"}
[2022-03-18T16:07:32,906][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"fb_apache", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0x524d2b77 @directory="/usr/share/logstash/modules/fb_apache/configuration", @module_name="fb_apache", @kibana_version_parts=["6", "0", "0"]>}
[2022-03-18T16:07:32,908][DEBUG][logstash.modules.scaffold] Found module {:module_name=>"netflow", :directory=>"/usr/share/logstash/modules/netflow/configuration"}
[2022-03-18T16:07:32,909][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"netflow", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0x9ec8290 @directory="/usr/share/logstash/modules/netflow/configuration", @module_name="netflow", @kibana_version_parts=["6", "0", "0"]>}
[2022-03-18T16:07:32,934][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby.jar:?]
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby.jar:?]
        at usr.share.logstash.lib.bootstrap.environment.<main>(/usr/share/logstash/lib/bootstrap/environment.rb:94) ~[?:?]

```

If I try to run

```auto
/usr/share/logstash/bin/logstash --config.test_and_exit -f /etc/logstash/conf.d/

```

everything goes well

any suggestions?  
Luca

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 15, 2022, 3:14pm UTC](https://discuss.elastic.co/t/logstash-8-1-0-1-fails-to-start/300059/2 "2022-04-15T15:14:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
