# Logstash 8.1.0 No appropriate protocol (protocol is disabled or cipher suites are inappropriate)

**URL:** <https://discuss.elastic.co/t/logstash-8-1-0-no-appropriate-protocol-protocol-is-disabled-or-cipher-suites-are-inappropriate/300582>\
**Category:** Logstash\
**Created:** [March 24, 2022, 2:18pm UTC](https://discuss.elastic.co/t/logstash-8-1-0-no-appropriate-protocol-protocol-is-disabled-or-cipher-suites-are-inappropriate/300582 "2022-03-24T14:18:14Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nandatibco](https://avatars.discourse-cdn.com/v4/letter/n/ed8c4c/32.png) [@nandatibco](https://discuss.elastic.co/u/nandatibco)\
**Post date:** [March 24, 2022, 2:18pm UTC](https://discuss.elastic.co/t/logstash-8-1-0-no-appropriate-protocol-protocol-is-disabled-or-cipher-suites-are-inappropriate/300582/1 "2022-03-24T14:18:14Z")

</div>

Hello team,

I'm using **Logstash 8.1.0 with plugin: logstash-input-websocket** , when I start Logstash getting below error:  
_[WARN][logstash.inputs.websocket][main][a0cd44e8c7bfa2705bff3d19091209cb115076d1199fdf41b74beb730f11ceb4] websocket input client threw exception, restarting {:exception=\>#\<OpenSSL::SSL::SSLError: No appropriate protocol (protocol is disabled or cipher suites are inappropriate)\>}_

Please suggest a solution.  
Thanks,  
Nandakishor

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 21, 2022, 2:18pm UTC](https://discuss.elastic.co/t/logstash-8-1-0-no-appropriate-protocol-protocol-is-disabled-or-cipher-suites-are-inappropriate/300582/2 "2022-04-21T14:18:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
