# Logstash 8.10.2 fails to start in docker without any log output

**URL:** <https://discuss.elastic.co/t/logstash-8-10-2-fails-to-start-in-docker-without-any-log-output/343973>\
**Category:** Logstash\
**Tags:** docker\
**Created:** [September 27, 2023, 10:36am UTC](https://discuss.elastic.co/t/logstash-8-10-2-fails-to-start-in-docker-without-any-log-output/343973 "2023-09-27T10:36:03Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![tzfun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tzfun/32/126052_2.png) [@tzfun](https://discuss.elastic.co/u/tzfun)\
**Post date:** [September 27, 2023, 10:36am UTC](https://discuss.elastic.co/t/logstash-8-10-2-fails-to-start-in-docker-without-any-log-output/343973/1 "2023-09-27T10:36:03Z")

</div>

I pulled image `docker.elastic.co/logstash/logstash:8.10.2` to run a container, and it works in docker on mac os but neither works in docker on Debian 11.

Docker for mac and debian 11 are both version `24.0.6`.

There is no log prompt when starting in debian docker:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/2/f/2f81fdc4001ea322d507fb1051698cab003a4479.png)

When I go into the container and try to start logstash manually, this is all the output:

```shell
root@docker-logstash:/usr/share/logstash/bin# ./logstash
Using bundled JDK: /usr/share/logstash/jdk
Killed

```

Has anyone encountered the same problem?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 25, 2023, 10:36am UTC](https://discuss.elastic.co/t/logstash-8-10-2-fails-to-start-in-docker-without-any-log-output/343973/2 "2023-10-25T10:36:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
