# Logstash and Kafka input issue

**URL:** https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848
**Category:** Logstash
**Created:** [March 18, 2016, 3:45pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848 "2016-03-18T15:45:10Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![HelpComputer](https://avatars.discourse-cdn.com/v4/letter/h/ac8455/32.png) [@HelpComputer](https://discuss.elastic.co/u/HelpComputer)
#### Post date: [March 18, 2016, 3:45pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/1 "2016-03-18T15:45:10Z")

</div>

Hello,

I am trying to setup the Kafka input in Logstash but something is not working right. Any help would be appreciated. Thanks in advance.

**Error Message on Server 2 in logstash.log**

`{:timestamp=>"2016-03-18T10:29:52.877000-0500", :message=>"kafka client threw exception, restarting", :exception=>#<KafkaError: Got ZkException: Unable to connect to zookeeper server within timeout: 6000>, :level=>:warn}`

My setup is like this:

**Server 1**

- logstash 2.2.2-1
- Kafka 2.11-0.9.0.1

input {  
udp {  
port =\> 5544  
type =\> "cisco-asa"  
}  
}  
output {  
kafka {  
topic\_id =\> "test"  
}  
}

**Server 2**

- logstash 2.2.2-1

input {  
kafka {  
zk\_connect =\> "Server1:2181"  
topic\_id =\> "test"  
}  
}

- For zk\_connect option on Server 2 I've tried using IP address and hostname of Server 1but both display same error above
- Confirmed test topic is in Kafka  
/opt/kafka\_2.11-0.9.0.1/bin/kafka-topics.sh --list --zookeeper localhost:2181  
test
- Confirmed that Server 1 is listening on port 2181
- Confirmed UDP input is being sent to Kafka test topic - /opt/kafka\_2.11-0.9.0.1/bin/kafka-console-consumer.sh --zookeeper localhost:2181 --topic test --from-beginning
- Zookeeper properties has maxClientCnxns=0

---

<div class="post-metadata">

### Author: ![HelpComputer](https://avatars.discourse-cdn.com/v4/letter/h/ac8455/32.png) [@HelpComputer](https://discuss.elastic.co/u/HelpComputer)
#### Post date: [March 18, 2016, 5:37pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/2 "2016-03-18T17:37:54Z")

</div>

This is a little embarrassing but it looks like I had the wrong subnet mask in my network config on Server 1. No longer seeing error in logstash logs.

---

<div class="post-metadata">

### Author: ![Joe\_Lawson](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_lawson/32/3390_2.png) [@Joe\_Lawson](https://discuss.elastic.co/u/Joe_Lawson)
#### Post date: [March 24, 2016, 6:13pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/3 "2016-03-24T18:13:57Z")

</div>

Glad it is working and thanks for following up!

---

<div class="post-metadata">

### Author: ![hearvishwas](https://avatars.discourse-cdn.com/v4/letter/h/cc9497/32.png) [@hearvishwas](https://discuss.elastic.co/u/hearvishwas)
#### Post date: [August 16, 2016, 1:09pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/4 "2016-08-16T13:09:59Z")

</div>

Hi,  
Its not working for me.  
I am able to inject data to kafka queue using logstash but unable to read.  
My conf are same as HelpComputer mentioned.  
Logstash starts but does not fetch data. No error is coming up.  
Kafka, localstash and elasticsearch are running on my local system.  
Any help is appreciated

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [August 16, 2016, 1:14pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/5 "2016-08-16T13:14:23Z")

</div>

Please start your own thread for this issue and provide more details about your configuration.

---

<div class="post-metadata">

### Author: ![hearvishwas](https://avatars.discourse-cdn.com/v4/letter/h/cc9497/32.png) [@hearvishwas](https://discuss.elastic.co/u/hearvishwas)
#### Post date: [August 16, 2016, 1:15pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/6 "2016-08-16T13:15:19Z")

</div>

How to start new thread?

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [August 16, 2016, 1:19pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/7 "2016-08-16T13:19:50Z")

</div>

Use the "New Topic" button that is available in the top right corner on, e.g. the landing page.

---

<div class="post-metadata">

### Author: ![hearvishwas](https://avatars.discourse-cdn.com/v4/letter/h/cc9497/32.png) [@hearvishwas](https://discuss.elastic.co/u/hearvishwas)
#### Post date: [August 16, 2016, 1:35pm UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/8 "2016-08-16T13:35:55Z")

</div>

created new topic:  
"[Logstash Input Plugin for kafka 0.9 is not working](https://discuss.elastic.co/t/logstash-input-plugin-for-kafka-0-9-is-not-working/58146)"

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 4:43am UTC](https://discuss.elastic.co/t/logstash-and-kafka-input-issue/44848/9 "2017-07-06T04:43:17Z")

</div>


