# Logstash as daemon won't start

**URL:** <https://discuss.elastic.co/t/logstash-as-daemon-wont-start/255716>\
**Category:** Logstash\
**Created:** [November 17, 2020, 2:34pm UTC](https://discuss.elastic.co/t/logstash-as-daemon-wont-start/255716 "2020-11-17T14:34:28Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [November 17, 2020, 2:34pm UTC](https://discuss.elastic.co/t/logstash-as-daemon-wont-start/255716/1 "2020-11-17T14:34:28Z")

</div>

I just upgraded system to 7.10.0  
this is test system. and logstash daemon won't start. here is result of

journalctl -xe

```
   start-up result is done.
Nov 17 08:28:25 elkdev01 logstash[13918]: Using bundled JDK: /usr/share/logstash/jdk
Nov 17 08:28:32 elkdev01 logstash[13918]: /usr/share/logstash/logstash-core-plugin-api/lib/logstash-core-plugin-api/version.rb:22: warning: The Psych YAML extension failed to load.
Nov 17 08:28:32 elkdev01 logstash[13918]: Check your env for conflicting versions of SnakeYAML
Nov 17 08:28:32 elkdev01 logstash[13918]: See https://github.com/jruby/jruby/wiki/FAQs#why-does-the-psych-yaml-extension-fail-to-load-in-my-environment
Nov 17 08:28:32 elkdev01 logstash[13918]: [ERROR] 2020-11-17 08:28:32.126 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (GemspecError)
Nov 17 08:28:32 elkdev01 logstash[13918]: [!] There was an error while loading `logstash-core-plugin-api.gemspec`: load error: psych -- java.lang.RuntimeException: BUG: we can not copy embedded jar to temp directory
Nov 17 08:28:32 elkdev01 logstash[13918]: Does it try to require a relative path? That's been removed in Ruby 1.9. Bundler cannot continue.
Nov 17 08:28:32 elkdev01 logstash[13918]: # from /usr/share/logstash/logstash-core-plugin-api/logstash-core-plugin-api.gemspec:23
Nov 17 08:28:32 elkdev01 logstash[13918]: # -------------------------------------------
Nov 17 08:28:32 elkdev01 logstash[13918]: #
Nov 17 08:28:32 elkdev01 logstash[13918]: > require "logstash-core-plugin-api/version"
Nov 17 08:28:32 elkdev01 logstash[13918]: #
Nov 17 08:28:32 elkdev01 logstash[13918]: # -------------------------------------------
Nov 17 08:28:32 elkdev01 systemd[1]: logstash.service: main process exited, code=exited, status=1/FAILURE
Nov 17 08:28:32 elkdev01 systemd[1]: Unit logstash.service entered failed state.
Nov 17 08:28:32 elkdev01 systemd[1]: logstash.service failed.
Nov 17 08:28:32 elkdev01 systemd[1]: logstash.service holdoff time over, scheduling restart.
Nov 17 08:28:32 elkdev01 systemd[1]: Stopped logstash.
-- Subject: Unit logstash.service has finished shutting down

```

I don't even get any log messages

java -version  
openjdk version "15.0.1" 2020-10-20  
OpenJDK Runtime Environment AdoptOpenJDK (build 15.0.1+9)  
OpenJDK 64-Bit Server VM AdoptOpenJDK (build 15.0.1+9, mixed mode, sharing)

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [November 17, 2020, 10:05pm UTC](https://discuss.elastic.co/t/logstash-as-daemon-wont-start/255716/2 "2020-11-17T22:05:25Z")

</div>

this is working now.  
it was actually problem with pipeline.yml file.  
it has one extra line at the end. as soon as I remove it it started working.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 15, 2020, 10:05pm UTC](https://discuss.elastic.co/t/logstash-as-daemon-wont-start/255716/3 "2020-12-15T22:05:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
