# Logstash asking filter file path

**URL:** <https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538>\
**Category:** Logstash\
**Created:** [October 1, 2018, 9:02am UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538 "2018-10-01T09:02:41Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)\
**Post date:** [October 1, 2018, 9:02am UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538/1 "2018-10-01T09:02:41Z")

</div>

Hi ,

I am using logstash 6.3.2 . Installed from rpm .

My issuse is my filter file's path is mentioned in logstash.yml .  
But again the logstash asking for filter file path .

My conf:

path.config: /etc/logstash/conf.d/filter.config

And the filter file is placed in /etc/logstash/conf.d/

When I am running the command

./bin/logstash -f /etc/logstash/conf.d/filter.config

LOgstash working.

When I am running this command ./bin/logstash  
Logstash asking filter file path

Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console  
ERROR: Failed to read pipelines yaml file. Location: /usr/share/logstash/config/pipelines.yml  
usage:  
bin/logstash -f CONFIG\_PATH [-t] [-r] [] [-w COUNT] [-l LOG]  
bin/logstash --modules MODULE\_NAME [-M "MODULE\_NAME.var.PLUGIN\_TYPE.PLUGIN\_NAME.VARIABLE\_NAME=VALUE"] [-t] [-w COUNT] [-l LOG]  
bin/logstash -e CONFIG\_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]  
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]  
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]  
bin/logstash --help  
[ERROR] 2018-10-01 09:00:51.576 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [October 3, 2018, 6:38pm UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538/2 "2018-10-03T18:38:34Z")

</div>

Where is your logstash.yml?

---

<div class="post-metadata">

**Author:** ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)\
**Post date:** [October 4, 2018, 4:44am UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538/3 "2018-10-04T04:44:43Z")

</div>

/etc/logstash/logstash.yml

---

<div class="post-metadata">

**Author:** ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)\
**Post date:** [October 4, 2018, 7:19am UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538/4 "2018-10-04T07:19:08Z")

</div>

I am installed form RPM file .

Because of that I am not created the $LS\_HOME

Is this make any problems ?

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [October 4, 2018, 7:27pm UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538/5 "2018-10-04T19:27:16Z")

</div>

No, but it's very surprising that Logstash complains about the non-existence of /etc/logstash/logstash.yml if you actually have a file there.

---

<div class="post-metadata">

**Author:** ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)\
**Post date:** [October 10, 2018, 4:31pm UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538/6 "2018-10-10T16:31:32Z")

</div>

Hi Self healed .

I am solved this by copied logstash.yml to /usr/share/logstash/config/

cp /etc/logstash/logstash.yml /usr/share/logstash/config/

Now without -f conf file path ./bin/logstash woking

./bin/logstash working now . Parsing the proper file

---

<div class="post-metadata">

**Author:** ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)\
**Post date:** [October 15, 2018, 9:35pm UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538/7 "2018-10-15T21:35:42Z")

</div>

Hi All ,

The error reasons founded.....

Reason LS\_HOME and LS\_SETTINGS\_DIR not entered:

From terminal try this command to set LS\_HOME and LS\_SETTINGS\_DIR

export LS\_HOME=/usr/share/logstash/  
export LS\_SETTINGS\_DIR=/etc/logstash/  
export PATH=$PATH:$LS\_HOME/bin  
export PATH

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 12, 2018, 9:35pm UTC](https://discuss.elastic.co/t/logstash-asking-filter-file-path/150538/8 "2018-11-12T21:35:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
