# Logstash benchmark

**URL:** <https://discuss.elastic.co/t/logstash-benchmark/373567>\
**Category:** Logstash\
**Created:** [January 23, 2025, 9:44am UTC](https://discuss.elastic.co/t/logstash-benchmark/373567 "2025-01-23T09:44:22Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![devops\_training](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/devops_training/32/131845_2.png) [@devops\_training](https://discuss.elastic.co/u/devops_training)\
**Post date:** [January 23, 2025, 9:44am UTC](https://discuss.elastic.co/t/logstash-benchmark/373567/1 "2025-01-23T09:44:22Z")

</div>

I see the below error in logstash

```auto
[2025-01-17T16:10:51,266][ERROR][logstash.outputs.elasticsearch][main][e65c1c48441d9162efee01ea49bd87b3c33b47189f25296954c014186f3f1bca] Encountered a retryable error (will retry with exponential backoff) {:code=>503, :url=>"https:// *************************************************************************** :443/_bulk", :content_length=>811}

```

1. How to handle this?
2. How to bench mark if logstash is able to handle the load?

please help.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [January 23, 2025, 12:44pm UTC](https://discuss.elastic.co/t/logstash-benchmark/373567/2 "2025-01-23T12:44:52Z")

</div>

If elasticsearch returns a 503 status then the logstash output will [retry forever](https://github.com/logstash-plugins/logstash-output-elasticsearch/blob/ec27adde4735d5a397875e5704a0487ec927c8b0/lib/logstash/plugin_mixins/elasticsearch/common.rb#L283) (the "For everything else there's mastercard" branch in the code) . There should be a more informative error message in the elasticsearch logs.

---

<div class="post-metadata">

**Author:** ![devops\_training](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/devops_training/32/131845_2.png) [@devops\_training](https://discuss.elastic.co/u/devops_training)\
**Post date:** [January 27, 2025, 3:16pm UTC](https://discuss.elastic.co/t/logstash-benchmark/373567/3 "2025-01-27T15:16:49Z")

</div>

Thank you Badger. Elastic search is down due to shards Initializing. After fixing it. This issue is resolved.
