# Logstash cloud central pipeline fails with configuration issue

**URL:** <https://discuss.elastic.co/t/logstash-cloud-central-pipeline-fails-with-configuration-issue/202490>\
**Category:** Logstash\
**Tags:** fleet\
**Created:** [October 7, 2019, 7:40am UTC](https://discuss.elastic.co/t/logstash-cloud-central-pipeline-fails-with-configuration-issue/202490 "2019-10-07T07:40:03Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![benoit1](https://avatars.discourse-cdn.com/v4/letter/b/73ab20/32.png) [@benoit1](https://discuss.elastic.co/u/benoit1)\
**Post date:** [October 7, 2019, 7:40am UTC](https://discuss.elastic.co/t/logstash-cloud-central-pipeline-fails-with-configuration-issue/202490/1 "2019-10-07T07:40:03Z")

</div>

Hi all,  
I'm testing an Azure Cloud deployement (Western Europe) and try to use the Kibana centralized Pipelines feature.  
I have a local Logstash instance that I want to register on my Cloud deployment.  
Local Logstash instance version is 6.8.3 running on centos.

The local logstash.yml is set as follows

```
path.data: /var/lib/logstash
cloud.id: deploy_01:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
cloud.auth: elastic:xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
path.logs: /var/log/logstash
xpack.management.enabled: true
xpack.management.pipeline.id: ["pipeline_01"]
xpack.management.elasticsearch.username: elastic
xpack.management.elasticsearch.password: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xpack.management.elasticsearch.hosts: ["https://xxxxxxxxxxxxxxxxxxxxxxx.westeurope.azure.elastic-cloud.com:9243/"]
xpack.management.logstash.poll_interval: 5s

```

I have created a pipeline on the Kibana Pipelines UI with ID = "pipeline\_01" and a basic configuration

```
input {
  beats {
    port => 5044
  }
}
filter {
}
output {
  stdout { codec => rubydebug }
}

```

When I run Logstash I keep on having the following message

```
[2019-10-07T09:27:51,527][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.

```

Full log is

```
[2019-10-07T09:27:33,753][INFO][logstash.configmanagement.bootstrapcheck] Using Elasticsearch as config store {:pipeline_id=>["pipeline_01"], :poll_interval=>"5000000000ns"}
[2019-10-07T09:27:35,229][INFO][logstash.configmanagement.elasticsearchsource] Configuration Management License OK
[2019-10-07T09:27:35,474][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"6.8.3"}
[2019-10-07T09:27:36,034][INFO][logstash.configmanagement.elasticsearchsource] Elasticsearch pool URLs updated {:changes=>{:removed=>[], :added=>[https://elastic:xxxxxx@xxxxxxxxxxxxxxxxxxxxxxxxxxxx.westeurope.azure.elastic-cloud.com:9243/]}}
[2019-10-07T09:27:36,133][WARN][logstash.configmanagement.elasticsearchsource] Restored connection to ES instance {:url=>"https://elastic:xxxxxx@xxxxxxxxxxxxxxxxxxxxxxxxxxxxx.westeurope.azure.elastic-cloud.com:9243/"}
[2019-10-07T09:27:36,240][INFO][logstash.configmanagement.elasticsearchsource] ES Output version determined {:es_version=>7}
[2019-10-07T09:27:36,240][WARN][logstash.configmanagement.elasticsearchsource] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document _type {:es_version=>7}
[2019-10-07T09:27:36,441][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2019-10-07T09:27:36,632][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2019-10-07T09:27:41,535][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2019-10-07T09:27:46,529][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2019-10-07T09:27:51,527][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.

```

I'm not sure where the issue is... in the local logstash.yml ? or I'm just not properly using the centralized Pipeline all together ?  
Any help would be appreciated !  
Many thanks

---

<div class="post-metadata">

**Author:** ![benoit1](https://avatars.discourse-cdn.com/v4/letter/b/73ab20/32.png) [@benoit1](https://discuss.elastic.co/u/benoit1)\
**Post date:** [October 8, 2019, 1:31pm UTC](https://discuss.elastic.co/t/logstash-cloud-central-pipeline-fails-with-configuration-issue/202490/2 "2019-10-08T13:31:39Z")

</div>

Issue is solved after installing logstash 7.4.0 !

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 5, 2019, 1:31pm UTC](https://discuss.elastic.co/t/logstash-cloud-central-pipeline-fails-with-configuration-issue/202490/3 "2019-11-05T13:31:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
