# Logstash.conf error

**URL:** <https://discuss.elastic.co/t/logstash-conf-error/321157>\
**Category:** Logstash\
**Created:** [December 13, 2022, 5:43pm UTC](https://discuss.elastic.co/t/logstash-conf-error/321157 "2022-12-13T17:43:45Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![limitless](https://avatars.discourse-cdn.com/v4/letter/l/9fc29f/32.png) [@limitless](https://discuss.elastic.co/u/limitless)\
**Post date:** [December 13, 2022, 5:43pm UTC](https://discuss.elastic.co/t/logstash-conf-error/321157/1 "2022-12-13T17:43:45Z")

</div>

.\bin\logstash.bat -f logstash.conf

"Using bundled JDK: A:\logstash-8.5.3\jdk\bin\java.exe"  
Sending Logstash logs to A:/logstash-8.5.3/logs which is now configured via log4j2.properties  
[2022-12-13T22:19:36,586][INFO][logstash.runner] Log4j configuration path used is: A:\logstash-8.5.3\config\log4j2.properties  
[2022-12-13T22:19:36,594][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"8.5.3", "jruby.version"=\>"jruby 9.3.9.0 (2.6.8) 2022-10-24 537cd1f8bc OpenJDK 64-Bit Server VM 17.0.5+8 on 17.0.5+8 +indy +jit [x86\_64-mswin32]"}  
[2022-12-13T22:19:36,610][INFO][logstash.runner] JVM bootstrap flags: [-Xms1g, -Xmx1g, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -Djruby.jit.threshold=0, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, -Djruby.regexp.interruptible=true, -Djdk.io.File.enableADS=true, --add-exports=jdk.compiler/com.sun.tools.javac.api=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.file=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.parser=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.tree=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.util=ALL-UNNAMED, --add-opens=java.base/java.security=ALL-UNNAMED, --add-opens=java.base/java.io=ALL-UNNAMED, --add-opens=java.base/java.nio.channels=ALL-UNNAMED, --add-opens=java.base/sun.nio.ch=ALL-UNNAMED, --add-opens=java.management/sun.management=ALL-UNNAMED]  
[2022-12-13T22:19:36,779][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2022-12-13T22:19:43,336][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=\>"A:/logstash-8.5.3/logstash.conf"}  
[2022-12-13T22:19:43,345][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.  
[2022-12-13T22:19:43,918][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600, :ssl\_enabled=\>false}  
[2022-12-13T22:19:43,984][INFO][logstash.runner] Logstash shut down.  
[2022-12-13T22:19:43,995][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit  
org.jruby.exceptions.SystemExit: (SystemExit) exit  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:790) ~[jruby.jar:?]  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:753) ~[jruby.jar:?]  
at A\_3a\_.logstash\_minus\_8\_dot\_5\_dot\_3.lib.bootstrap.environment.(A:\logstash-8.5.3\lib\bootstrap\environment.rb:91) ~[?:?]

can someone please help me sort out this error.  
the logstash.conf file is as below:

inpu{  
file{  
path =\> "A:/dataset/2013\_Salaries\_\_Pennsylvania\_State\_System\_of\_Higher\_Education.csv"  
start\_position =\> "beginning"  
sincedb\_path =\> "NULL"

}  
}  
filter{  
csv {  
separator =\> ","  
columns =\> ["index","Name","Base Pay","University or Office","Position"]  
}

}  
output {  
elasticsearch {

```
    hosts => "http://localhost:9200"
    index => "higher_edu_salaries"
}
stdout {}

```

}

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [December 13, 2022, 6:57pm UTC](https://discuss.elastic.co/t/logstash-conf-error/321157/2 "2022-12-13T18:57:04Z")

</div>

> [@limitless](#):
>
> [logstash.config.source.local.configpathloader] No config files found in path {:path=\>"A:/logstash-8.5.3/logstash.conf"}

It is not finding that file.

Been a while since I saw a computer with an A: drive!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 10, 2023, 6:57pm UTC](https://discuss.elastic.co/t/logstash-conf-error/321157/3 "2023-01-10T18:57:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
