# Logstash Configuration file is not working its giving error

**URL:** <https://discuss.elastic.co/t/logstash-configuration-file-is-not-working-its-giving-error/119911>\
**Category:** Logstash\
**Created:** [February 15, 2018, 5:59am UTC](https://discuss.elastic.co/t/logstash-configuration-file-is-not-working-its-giving-error/119911 "2018-02-15T05:59:59Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Krunal\_kalaria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krunal_kalaria/32/23862_2.png) [@Krunal\_kalaria](https://discuss.elastic.co/u/Krunal_kalaria)\
**Post date:** [February 15, 2018, 5:59am UTC](https://discuss.elastic.co/t/logstash-configuration-file-is-not-working-its-giving-error/119911/1 "2018-02-15T05:59:59Z")

</div>

Hello All,

I am using Elastic Stack 6.2.0.

Elasticsearch and Kibana working fine but When i run any logstash config file then its giving following error:

WARNING: Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console  
[INFO] 2018-02-15 11:08:59.847 [main] scaffold - Initializing module {:module\_name=\>"fb\_apache", :directory=\>"/usr/share/logstash/modules/fb\_apache/configuration"}  
[INFO] 2018-02-15 11:08:59.855 [main] scaffold - Initializing module {:module\_name=\>"netflow", :directory=\>"/usr/share/logstash/modules/netflow/configuration"}  
[FATAL] 2018-02-15 11:08:59.883 [main] runner - An unexpected error occurred! {:error=\>#\<ArgumentError: Path "/usr/share/logstash/data" must be a writable directory. It is not writable.\>, :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:448:in `validate'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:230:in`validate\_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:141:in `block in validate_all'", "org/jruby/RubyHash.java:1343:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:140:in `validate_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:264:in`execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:219:in`run'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:67:in`'"]}  
**[ERROR] 2018-02-15 11:08:59.889 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (SystemExit) exit**

Please help me to resolve this problem.

Thanks & Regards,  
Krunal.

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [February 15, 2018, 7:00am UTC](https://discuss.elastic.co/t/logstash-configuration-file-is-not-working-its-giving-error/119911/2 "2018-02-15T07:00:35Z")

</div>

> Path "/usr/share/logstash/data" must be a writable directory. It is not writable.

Here's the problem in plain text.

---

<div class="post-metadata">

**Author:** ![Krunal\_kalaria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krunal_kalaria/32/23862_2.png) [@Krunal\_kalaria](https://discuss.elastic.co/u/Krunal_kalaria)\
**Post date:** [February 16, 2018, 4:40am UTC](https://discuss.elastic.co/t/logstash-configuration-file-is-not-working-its-giving-error/119911/3 "2018-02-16T04:40:33Z")

</div>

Thnks @magnusbaeck for reaching out it solved now.

---

<div class="post-metadata">

**Author:** ![Sanchez\_roxx](https://avatars.discourse-cdn.com/v4/letter/s/258eb7/32.png) [@Sanchez\_roxx](https://discuss.elastic.co/u/Sanchez_roxx)\
**Post date:** [February 17, 2018, 12:34pm UTC](https://discuss.elastic.co/t/logstash-configuration-file-is-not-working-its-giving-error/119911/4 "2018-02-17T12:34:27Z")

</div>

Hy Guys,

I try to configure the Elastic Stack 6.2.1 in Docker but I am not able to get Logstash running:

I dont know what to do, I am trying this for 3 days now:

Here is my console log:  
logstash | Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console  
logstash | [INFO] 2018-02-17 12:31:49.165 [main] scaffold - Initializing module {:module\_name=\>"netflow", :directory=\>"/usr/share/logstash/modules/netflow/configuration"}  
logstash | [INFO] 2018-02-17 12:31:49.170 [main] scaffold - Initializing module {:module\_name=\>"fb\_apache", :directory=\>"/usr/share/logstash/modules/fb\_apache/configuration"}  
logstash | [INFO] 2018-02-17 12:31:49.660 [main] scaffold - Initializing module {:module\_name=\>"arcsight", :directory=\>"/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/x-pack-6.2.1-java/modules/arcsight/configuration"}  
logstash | [FATAL] 2018-02-17 12:31:49.677 [main] runner - An unexpected error occurred! {:error=\>#\<ArgumentError: Setting "elasticsearch.url" hasn't been registered\>, :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:37:in `get_setting'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:70:in`set\_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:89:in `block in merge'", "org/jruby/RubyHash.java:1343:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:89:in `merge'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:138:in`validate\_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:264:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in`run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:219:in `run'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in`run'", "/usr/share/logstash/lib/bootstrap/environment.rb:67:in `'"]}  
logstash | [ERROR] 2018-02-17 12:31:49.681 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (SystemExit) exit

Please help me to resolve this problem.

Sanchez (not a mexican)

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [February 17, 2018, 8:45pm UTC](https://discuss.elastic.co/t/logstash-configuration-file-is-not-working-its-giving-error/119911/5 "2018-02-17T20:45:34Z")

</div>

@Sanchez_roxx, please start your own thread for your unrelated problem.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 17, 2018, 8:45pm UTC](https://discuss.elastic.co/t/logstash-configuration-file-is-not-working-its-giving-error/119911/6 "2018-03-17T20:45:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
