# Logstash configuration issue(message=\>"Could not execute action)

**URL:** <https://discuss.elastic.co/t/logstash-configuration-issue-message-could-not-execute-action/201900>\
**Category:** Logstash\
**Created:** [October 2, 2019, 7:04am UTC](https://discuss.elastic.co/t/logstash-configuration-issue-message-could-not-execute-action/201900 "2019-10-02T07:04:50Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![vijayakrishna.rg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vijayakrishna.rg/32/36798_2.png) [@vijayakrishna.rg](https://discuss.elastic.co/u/vijayakrishna.rg)\
**Post date:** [October 2, 2019, 7:04am UTC](https://discuss.elastic.co/t/logstash-configuration-issue-message-could-not-execute-action/201900/1 "2019-10-02T07:04:50Z")

</div>

Logstash: 7.3.0  
Elastic: 7.3.0  
filebeat: 7.3.0

i am configuring logstash on one of the Redhat machine to forward nginx logs, getting below issue, can someone please suggest me, Thanks.

nginx.conf

```
input {
beats {
          host => "10.10.10.10"
    port => 5400
}
}

filter {
  dissect { mapping => { "message" => "[%{[@metadata][timestamp]}] %{[@metadata][kvData]}" } }
  kv { source => "[@metadata][kvData]" }
  date { match => ["[@metadata][timestamp]", "YYYY-MM-dd'T'HH:mm:ssZZ" ] }
}

output {
 elasticsearch {
   hosts => ["nprod-elastic.net:443"]
   index => "nprod-nginx-logstash-%{+yyyy.MM.dd}"
   ssl => true
   cacert => "/etc/pki/root/ca.pem"
   user => admin
   password => changeme
 }
 stdout { codec => rubydebug }
}

```

Logstash Config check:

```
/usr/share/logstash/bin/logstash -t -f /etc/logstash/conf.d/ --path.settings /etc/logstash/
Thread.exclusive is deprecated, use Thread::Mutex
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
[2019-10-02T05:52:38,958][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2019-10-02T05:52:41,216][INFO][org.reflections.Reflections] Reflections took 52 ms to scan 1 urls, producing 19 keys and 39 values

```

Configuration OK  
[2019-10-02T05:52:43,396][INFO][logstash.runner] Using config.test\_and\_exit mode. Config Validation Result: OK. Exiting Logstash

logs:

```
[2019-10-02T06:29:39,542][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.3.0"}
[2019-10-02T06:29:42,594][INFO][org.reflections.Reflections] Reflections took 79 ms to scan 1 urls, producing 19 keys and 39 values
[2019-10-02T06:29:45,923][ERROR][logstash.javapipeline] h/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/client.rb)", "usr.share.logstash."java.lang.Thread.run(java/lang/Thread.java:748)"], :thread=>"#<Thread:0x3a15e31a run>"}
[2019-10-02T06:29:45,962][ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[2019-10-02T06:29:46,424][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2019-10-02T06:29:51,349][INFO][logstash.runner] Logstash shut down.
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 30, 2019, 7:05am UTC](https://discuss.elastic.co/t/logstash-configuration-issue-message-could-not-execute-action/201900/2 "2019-10-30T07:05:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
