# Logstash could not connet to influxdb

**URL:** https://discuss.elastic.co/t/logstash-could-not-connet-to-influxdb/171481
**Category:** Logstash
**Created:** [March 8, 2019, 11:26am UTC](https://discuss.elastic.co/t/logstash-could-not-connet-to-influxdb/171481 "2019-03-08T11:26:05Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![lina.sun](https://avatars.discourse-cdn.com/v4/letter/l/aeb1de/32.png) [@lina.sun](https://discuss.elastic.co/u/lina.sun)
#### Post date: [March 8, 2019, 11:26am UTC](https://discuss.elastic.co/t/logstash-could-not-connet-to-influxdb/171481/1 "2019-03-08T11:26:06Z")

</div>

i want to use UDP port to write metric to influxdb. when i use 8086 ,it Operating normally。but when i change the port to 8089 .It  
Will report an error.

my logstash config:

 ![%E4%BC%81%E4%B8%9A%E5%BE%AE%E4%BF%A1%E6%88%AA%E5%9B%BE_20190308192026](https://us1.discourse-cdn.com/elastic/original/3X/2/e/2e4b42059c62aa37b3cbc4981f59dabf52de36da.png)

influxdb config:

[[udp]]  
enabled = true  
bind-address = ":8089"  
database = "apigw\_log"

error:

[2019-03-08T18:17:54,455][WARN][logstash.outputs.influxdb] Connection Error while writing to InfluxDB {:exception=\>#\<InfluxDB::ConnectionError: Tried 3 times to reconnect but failed.\>}  
E, [2019-03-08T18:17:54.570000 #5173] ERROR -- InfluxDB: Failed to contact host 172.27.116.154: #\<Errno::ECONNREFUSED: Connection refused - Connection refused\> - retrying in 1s.  
E, [2019-03-08T18:17:55.606000 #5173] ERROR -- InfluxDB: Failed to contact host 172.27.116.154: #\<Errno::ECONNREFUSED: Connection refused - Connection refused\> - retrying in 2s

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 5, 2019, 11:26am UTC](https://discuss.elastic.co/t/logstash-could-not-connet-to-influxdb/171481/2 "2019-04-05T11:26:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
