# Logstash crashes after sometime and freezes the system

**URL:** <https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848>\
**Category:** Logstash\
**Created:** [September 8, 2015, 3:36pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848 "2015-09-08T15:36:26Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 8, 2015, 3:36pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/1 "2015-09-08T15:36:26Z")

</div>

I am using logstash to feed elasticsearch indices data from my couchdb. I have about 20 indices. At this time I have very simple setup. All my data is in different databases in couchDB, e.g., users has its own db, roles has its own db and so on and I have indices for each of the db.  
For some reason, logstash freezes my system after throwing some errors after running for 10 minutes or so. The errors are related to plugin failure for few indices. I was not able to copy the errors due to freeze. Please advice, how can I resolve the freeze. I'll post errors as soon as I copy those.

Many thanks.

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 8, 2015, 5:35pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/2 "2015-09-08T17:35:36Z")

</div>

Here is the error:  
?[31mA plugin had an unrecoverable error. Will restart this plugin.  
Plugin: \<LogStash::Inputs::CouchDBChanges db=\>"audits", host=\>"127.0.0.1", por  
t=\>5984, sequence\_path=\>"seq\_files\audits\_couchdb\_seq", tags=\>["audits"], debug  
=\>false, codec=\>\<LogStash::Codecs::Plain charset=\>"UTF-8"\>, secure=\>false, passw  
ord=\>, heartbeat=\>1000, keep\_revision=\>false, ignore\_attachments=\>true  
, always\_reconnect=\>true, reconnect\_delay=\>10\>  
Error: Unable to establish loopback connection {:level=\>:error}?[0m  
?[31mA plugin had an unrecoverable error. Will restart this plugin.  
Plugin: \<LogStash::Inputs::CouchDBChanges db=\>"links", host=\>"127.0.0.1", port  
=\>5984, sequence\_path=\>"seq\_files\links\_couchdb\_seq", tags=\>["links"], debug=\>f  
alse, codec=\>\<LogStash::Codecs::Plain charset=\>"UTF-8"\>, secure=\>false, password  
=\>, heartbeat=\>1000, keep\_revision=\>false, ignore\_attachments=\>true, a  
lways\_reconnect=\>true, reconnect\_delay=\>10\>  
Error: Unable to establish loopback connection {:level=\>:error}?[0m  
?[31mA plugin had an unrecoverable error. Will restart this plugin.  
Plugin: \<LogStash::Inputs::CouchDBChanges db=\>"cameras", host=\>"127.0.0.1", po  
rt=\>5984, sequence\_path=\>"seq\_files\cameras\_couchdb\_seq", tags=\>["cameras"], de  
bug=\>false, codec=\>\<LogStash::Codecs::Plain charset=\>"UTF-8"\>, secure=\>false, pa  
ssword=\>, heartbeat=\>1000, keep\_revision=\>false, ignore\_attachments=\>t  
rue, always\_reconnect=\>true, reconnect\_delay=\>10\>  
Error: Unable to establish loopback connection {:level=\>:error}?[0m

---

<div class="post-metadata">

**Author:** ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)\
**Post date:** [September 8, 2015, 7:54pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/3 "2015-09-08T19:54:54Z")

</div>

Thanks @imad,

Are you able to post your logstash configuration?

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 9, 2015, 2:19am UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/4 "2015-09-09T02:19:04Z")

</div>

Here is how my config file looks like:

input {  
# 1 attributes  
couchdb\_changes {  
db =\> "attributes"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\attributes\_couchdb\_seq"  
tags =\> ["attributes"]  
}  
# 2 audits  
couchdb\_changes {  
db =\> "audits"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\audits\_couchdb\_seq"  
tags =\> ["audits"]  
}  
couchdb\_changes {  
db =\> "clips"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\clips\_couchdb\_seq"  
tags =\> ["clips"]  
}  
couchdb\_changes {  
db =\> "events"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\events\_couchdb\_seq"  
tags =\> ["events"]  
}  
couchdb\_changes {  
db =\> "folder"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\folder\_couchdb\_seq"  
tags =\> ["folder"]  
}  
couchdb\_changes {  
db =\> "icons"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\icons\_couchdb\_seq"  
tags =\> ["icons"]  
}  
couchdb\_changes {  
db =\> "menus"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\menus\_couchdb\_seq"  
tags =\> ["menus"]  
}  
couchdb\_changes {  
db =\> "users"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\users\_couchdb\_seq"  
tags =\> ["users"]  
}  
couchdb\_changes {  
db =\> "roles"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\roles\_couchdb\_seq"  
tags =\> ["roles"]  
}  
couchdb\_changes {  
db =\> "cameras"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\cameras\_couchdb\_seq"  
tags =\> ["cameras"]  
}  
couchdb\_changes {  
db =\> "devices"  
host =\> "127.0.0.1"  
port =\> 5984  
sequence\_path =\> "seq\_files\devices\_couchdb\_seq"  
tags =\> ["devices"]  
}  
}  
output {  
if "attributes" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "attributes\_index"  
protocol =\> "http"  
port =\> 9200  
}  
}  
if "audits" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "audits\_index"  
protocol =\> "http"  
port =\> 9200  
}  
}  
if "clips" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "clips\_index"  
protocol =\> "http"  
port =\> 9200  
}  
}  
if "events" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "events\_index"  
protocol =\> "http"  
port =\> 9200  
}  
}  
if "folder" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "folder\_index"  
protocol =\> "http"  
port =\> 9200  
}  
}  
if "icons" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "icons\_index"  
protocol =\> "http"  
port =\> 9200  
}  
}  
if "menus" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "menus\_index"  
protocol =\> "http"  
port =\> 9200  
}  
}  
if "users" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "users\_index"  
protocol =\> "http"  
host =\> '127.0.0.1'  
port =\> 9200  
}  
}  
if "roles" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "roles\_index"  
protocol =\> "http"  
host =\> '127.0.0.1'  
port =\> 9200  
}  
}  
if "cameras" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "cameras\_index"  
protocol =\> "http"  
host =\> '127.0.0.1'  
port =\> 9200  
}  
}  
if "devices" in [tags] {  
elasticsearch {  
document\_id =\> "%{[@metadata][\_id]}"  
host =\> "127.0.0.1"  
index =\> "devices\_index"  
protocol =\> "http"  
host =\> '127.0.0.1'  
port =\> 9200  
}  
}  
}

---

<div class="post-metadata">

**Author:** ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)\
**Post date:** [September 9, 2015, 2:25am UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/5 "2015-09-09T02:25:53Z")

</div>

@imad,

My initial feeling is simply that logstash cannot connect to the CouchDB server @ 127.0.0.1. Is it possibly that the CouchDB server stops responding or will not take new connections at some point?

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 9, 2015, 2:49pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/6 "2015-09-09T14:49:48Z")

</div>

No, I don't think so, since we are querying couchdb all the time.

---

<div class="post-metadata">

**Author:** ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)\
**Post date:** [September 9, 2015, 3:28pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/7 "2015-09-09T15:28:34Z")

</div>

If things crash after only 10 minutes, consistently, then we must be able to track the reason.

1. Are you running iptables or any firewall that would prevent localhost connections in any way?

2. Please run the following periodically (assuming you are running in posix enviroment) from start until crash. Let's see if the number of connections remains constant.

3. Also, you can run logstash with --debug, in order to capture any other information that might lead to the solution.

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 9, 2015, 7:56pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/8 "2015-09-09T19:56:23Z")

</div>

Phaedrus thanks for your reply.

Actually the crash is not consistently happening after 10 mins, its arbitrary. I ran netstat -an command consistently and only saw same number of connections just few minutes before crash.  
I can share the log file that I captured by running logstash with --debug flag. But I didn't see any error in the log file for crash. Is there a way to upload it or send it to you?

---

<div class="post-metadata">

**Author:** ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)\
**Post date:** [September 9, 2015, 8:09pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/9 "2015-09-09T20:09:41Z")

</div>

You can upload the logs using gist, pastebin, or even dropbox, depending on the size.

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 9, 2015, 8:55pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/10 "2015-09-09T20:55:21Z")

</div>

> [@PhaedrusTheGreek](#):
>
> gist

here is the gist link for log file : [logstash\_log - test.txt · GitHub](https://gist.github.com/imadulhaque/4bfdba5d99cdfdb11b6d). Let me know if it doesn't work.

Thanks.

---

<div class="post-metadata">

**Author:** ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)\
**Post date:** [September 9, 2015, 9:03pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/11 "2015-09-09T21:03:28Z")

</div>

When the system freezes, can you describe what happens? Are you able to SSH into the host? Must you reboot the system manually? There must be some indication from an operational perspective as to what is causing the lockup. For example, is there memory or CPU contention at that time?

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 9, 2015, 9:26pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/12 "2015-09-09T21:26:46Z")

</div>

I don't see any CPU contention, looks like enough memory is available when system freezes. I can't do anything when system freezes until I manually press restart button.

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 10, 2015, 3:04pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/13 "2015-09-10T15:04:18Z")

</div>

Any help on this. Just an fyi, I am running elasticsearch and logstash on same system that has my couchdb.

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 11, 2015, 7:14pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/14 "2015-09-11T19:14:53Z")

</div>

@PhaedrusTheGreek could it be that when a document is updated in couchdb, for some reason logstash fails to update that document in its corresponding index in elasticsearch.

I have uploaded a crash dump at: [https://gist.github.com/imadulhaque/6d405fb57042182e6166](https://gist.github.com/imadulhaque/6d405fb57042182e6166).  
The last message that I see is message=\>"failed action with response of 400, dropping action: ["index", {:\_id=\>"51f4314a442fbf205072f60cdb0309d1", :\_index=\>"users\_index", :\_type=\>"logs", :\_routing=\>nil},.............  
Could this be the reason for logstash freeze and eventually system freeze?  
Any help would be greatly appreciated.

Thanks.

---

<div class="post-metadata">

**Author:** ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)\
**Post date:** [September 11, 2015, 7:58pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/15 "2015-09-11T19:58:32Z")

</div>

@imad

Running CouchDB, Logstash & Elasticsearch all on the same system may be related to the problem, but I think that fact confuses the issue. I would recommend splitting the 3 functions out against 3 different machines . By doing this, we may gain more insight into where the failure is occurring.

Also, I am interested to know the JVM version(s), OS, Logstash & Elasticsearch Versions.

Thanks

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 11, 2015, 8:50pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/16 "2015-09-11T20:50:16Z")

</div>

In our first release we would be running everything on same machine with enough memory for them.  
So do you mean, even elasticsearch + logstash on same system is also not recommended?

java version "1.8.0\_51"  
Java(TM) SE Runtime Environment (build 1.8.0\_51-b16)  
Java HotSpot(TM) 64-Bit Server VM (build 25.51-b03, mixed mode)

OS is windows 7 64 bit.  
logstash is1.5.4  
elasticsearch is 1.6.2

---

<div class="post-metadata">

**Author:** ![PhaedrusTheGreek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phaedrusthegreek/32/4884_2.png) [@PhaedrusTheGreek](https://discuss.elastic.co/u/PhaedrusTheGreek)\
**Post date:** [September 11, 2015, 9:37pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/17 "2015-09-11T21:37:51Z")

</div>

I see some discrepancies between your environment and the supported platforms documentation. Please see here:

[https://www.elastic.co/support/matrix](https://www.elastic.co/support/matrix)

It's always better to run separate components on dedicated systems, so that they don't contend for resources with each other. Further, it will help us isolate the problem.

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 14, 2015, 4:22pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/18 "2015-09-14T16:22:34Z")

</div>

I updated my jdk and jre to latest version. Then downloaded latest elasticsearch, unzipped it and tried to install it as service but its failing but it runs without any error. Any ideas whats up with the 'service install' thing. This is the error that I get:

Installing service : "elasticsearch-service-x64"  
Using JAVA\_HOME (64-bit): "C:\Program Files\Java\jdk1.8.0\_60"  
Failed installing 'elasticsearch-service-x64' service

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 14, 2015, 6:28pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/19 "2015-09-14T18:28:42Z")

</div>

Just an fyi, I tried latest version of jre and jdk with latest version of elasticearch 1.7.2 and logstash 1.5.4 and still got the same error with system freeze. I'll run elasticsearch and logstash on different system to see if it make any difference.

Here are the errors, but no its for different couchdb and elastic search index.  
{:timestamp=\>"2015-09-14T13:23:40.330000-0400", :message=\>"A plugin had an unrecoverable error. Will restart this plugin.\n Plugin: \<LogStash::Inputs::CouchDBChanges db=\>"preferences", host=\>"127.0.0.1", port=\>5984, sequence\_path=\>"seq\_files\\preferences\_couchdb\_seq", tags=\>["preferences"], debug=\>false, codec=\>\<LogStash::Codecs::Plain charset=\>"UTF-8"\>, secure=\>false, password=\>, heartbeat=\>1000, keep\_revision=\>false, ignore\_attachments=\>true, always\_reconnect=\>true, reconnect\_delay=\>10\>\n Error: Unable to establish loopback connection\n Exception: IOError\n Stack: org/jruby/RubyIO.java:3682:in `select'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/protocol.rb:143:in`rbuf\_fill'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/protocol.rb:141:in `rbuf_fill'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/protocol.rb:122:in`readuntil'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/protocol.rb:132:in `readline'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:2779:in`read\_chunked'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:2759:in `read_body_0'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:2719:in`read\_body'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/bundle/jruby/1.9/gems/logstash-input-couchdb\_changes-1.0.0/lib/logstash/inputs/couchdb\_changes.rb:147:in `run'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:1331:in`transport\_request'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:2680:in `reading_body'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:1330:in`transport\_request'\norg/jruby/RubyKernel.java:1274:in `catch'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:1325:in`transport\_request'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:1302:in `request'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/bundle/jruby/1.9/gems/logstash-input-couchdb_changes-1.0.0/lib/logstash/inputs/couchdb_changes.rb:145:in`run'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:746:in `start'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/jruby/lib/ruby/1.9/net/http.rb:557:in`start'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/bundle/jruby/1.9/gems/logstash-input-couchdb\_changes-1.0.0/lib/logstash/inputs/couchdb\_changes.rb:141:in `run'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.4-java/lib/logstash/pipeline.rb:177:in`inputworker'\nE:/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.4-java/lib/logstash/pipeline.rb:171:in `start\_input'", :level=\>:error, :file=\>"/Softwares/Web Related/logstash-1.5.4/logstash-1.5.4/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.4-java/lib/logstash/pipeline.rb", :line=\>"182", :method=\>"inputworker"}

---

<div class="post-metadata">

**Author:** ![imad](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@imad](https://discuss.elastic.co/u/imad)\
**Post date:** [September 14, 2015, 8:36pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848/20 "2015-09-14T20:36:26Z")

</div>

@PhaedrusTheGreek thanks for all your help. Looks like there was something wrong on my system for elasticsearch to run as service. I have installled latest jre and jdk on one of my other systems and using latest elasticsearch and logstash on it. The whole system seems to works fine so far, whereas earlier it would freeze in about 20 to 30 mins. The system that I have with new setup has more memory as well so it means system freeze was most probably due to lack of memory.

[Next page](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848.md?page=2)
