# Logstash crashes with libcrypt-2.12.so - works with libcrypt-2.5.so

**URL:** https://discuss.elastic.co/t/logstash-crashes-with-libcrypt-2-12-so-works-with-libcrypt-2-5-so/32683
**Category:** Logstash
**Created:** [October 21, 2015, 3:13pm UTC](https://discuss.elastic.co/t/logstash-crashes-with-libcrypt-2-12-so-works-with-libcrypt-2-5-so/32683 "2015-10-21T15:13:59Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Shailen](https://avatars.discourse-cdn.com/v4/letter/s/50afbb/32.png) [@Shailen](https://discuss.elastic.co/u/Shailen)
#### Post date: [October 21, 2015, 3:13pm UTC](https://discuss.elastic.co/t/logstash-crashes-with-libcrypt-2-12-so-works-with-libcrypt-2-5-so/32683/1 "2015-10-21T15:13:59Z")

</div>

This error was reported in the past as "block device detection unsupported or native support failed to load" with missing links for libcrypt.so. In this case, all links were correct but a new version 2.12 of the library caused logstash to give the same error. Version 2-5.so works. The work-around was to copy the older file in a local area and change the LD\_LIBRARY\_PATH to point to 2-5

I am working on Red Hat Enterprise Linux Server release 6.6 (Santiago).

Could you folks please look into fixing this?

Thank you

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 5:25am UTC](https://discuss.elastic.co/t/logstash-crashes-with-libcrypt-2-12-so-works-with-libcrypt-2-5-so/32683/2 "2017-07-06T05:25:54Z")

</div>


