# Logstash docker error -\> exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of \[ \\\\t\\\\r\\\\n\], \\"#\\", \\"input\\", \\"filter\\", \\"output\\" at line 1, column 1 (byte 1)"

**URL:** https://discuss.elastic.co/t/logstash-docker-error-exception-logstash-configurationerror-message-expected-one-of-t-r-n-input-filter-output-at-line-1-column-1-byte-1/255210
**Category:** Logstash
**Created:** [November 12, 2020, 12:18pm UTC](https://discuss.elastic.co/t/logstash-docker-error-exception-logstash-configurationerror-message-expected-one-of-t-r-n-input-filter-output-at-line-1-column-1-byte-1/255210 "2020-11-12T12:18:27Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![s0umen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/s0umen/32/78903_2.png) [@s0umen](https://discuss.elastic.co/u/s0umen)
#### Post date: [November 12, 2020, 12:18pm UTC](https://discuss.elastic.co/t/logstash-docker-error-exception-logstash-configurationerror-message-expected-one-of-t-r-n-input-filter-output-at-line-1-column-1-byte-1/255210/1 "2020-11-12T12:18:27Z")

</div>

Hi,  
I am facing a peculiar issue. I have seen the error faced by many before me, but the solution (only a few of them said resolved by fresh creation by typing the logstash.conf file) is not working for me.

Please help.

I am trying to run following command...

docker run --rm -it -v "$(pwd)"/pipeline/:/usr/share/logstash/pipeline/ [docker.elastic.co/logstash/logstash-oss:7.10.0](http://docker.elastic.co/logstash/logstash-oss:7.10.0)

This actually behave exactly similar way for litlle older version like 7.9.3 as well.

my logstash.conf file in a subdirectory /config of current directory (from where I fired this command) has following lines.....  
input{  
tcp {  
port =\> 5044  
codec =\> json  
type =\> logstash  
}  
}  
output{  
elasticsearch {  
hosts =\> "elasticsearch-elkpoc:80"  
index =\> "%{type}-%{+YYYY.MM.DD}"  
}  
}

This resulted out with the following error....  
LogStash::ConfigurationError", :message=\>"Expected one of [\t\r\n], "#", "input", "filter", "output" at line 1, column 1 (byte 1)"

The error remains same even if I reduce the logstash.conf to  
input{} output{} filter{}

Entire error message below...  
Using bundled JDK: /usr/share/logstash/jdk  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by org.jruby.ext.openssl.SecurityHelper (file:/tmp/jruby-1/jruby17367836674706560272jopenssl.jar) to field java.security.MessageDigest.provider  
WARNING: Please consider reporting this to the maintainers of org.jruby.ext.openssl.SecurityHelper  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
Sending Logstash logs to /usr/share/logstash/logs which is now configured via log4j2.properties  
[2020-11-12T11:55:37,170][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.10.0", "jruby.version"=\>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc OpenJDK 64-Bit Server VM 11.0.8+10 on 11.0.8+10 +indy +jit [linux-x86\_64]"}  
[2020-11-12T11:55:37,357][INFO][logstash.setting.writabledirectory] Creating directory {:setting=\>"path.queue", :path=\>"/usr/share/logstash/data/queue"}  
[2020-11-12T11:55:37,392][INFO][logstash.setting.writabledirectory] Creating directory {:setting=\>"path.dead\_letter\_queue", :path=\>"/usr/share/logstash/data/dead\_letter\_queue"}  
[2020-11-12T11:55:38,302][INFO][logstash.agent] No persistent UUID file found. Generating new UUID {:uuid=\>"97d3f9dd-7c24-4649-a056-04a9901f1b87", :path=\>"/usr/share/logstash/data/uuid"}  
[2020-11-12T11:55:41,024][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of [\t\r\n], "#", "input", "filter", "output" at line 1, column 1 (byte 1)", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:32:in `compile_imperative'", "org/logstash/execution/AbstractPipelineExt.java:184:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:69:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:47:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:52:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:365:in `block in converge\_state'"]}  
[2020-11-12T11:55:41,602][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2020-11-12T11:55:46,368][INFO][logstash.runner] Logstash shut down.  
[2020-11-12T11:55:46,421][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

---

<div class="post-metadata">

### Author: ![fadjar340](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fadjar340/32/43610_2.png) [@fadjar340](https://discuss.elastic.co/u/fadjar340)
#### Post date: [November 13, 2020, 1:33pm UTC](https://discuss.elastic.co/t/logstash-docker-error-exception-logstash-configurationerror-message-expected-one-of-t-r-n-input-filter-output-at-line-1-column-1-byte-1/255210/2 "2020-11-13T13:33:43Z")

</div>

Please use the proper format of the conf:

```auto
input {
   tcp {
   port => 5044
   codec => json
   type => logstash
   }
}

filter {
}

output {
   elasticsearch {
   hosts => "elasticsearch-elkpoc:80"
   index => "%{type}-%{+YYYY.MM.DD}"
   }
}

```

---

<div class="post-metadata">

### Author: ![s0umen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/s0umen/32/78903_2.png) [@s0umen](https://discuss.elastic.co/u/s0umen)
#### Post date: [November 17, 2020, 11:55am UTC](https://discuss.elastic.co/t/logstash-docker-error-exception-logstash-configurationerror-message-expected-one-of-t-r-n-input-filter-output-at-line-1-column-1-byte-1/255210/3 "2020-11-17T11:55:59Z")

</div>

thanks it helped

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 15, 2020, 11:56am UTC](https://discuss.elastic.co/t/logstash-docker-error-exception-logstash-configurationerror-message-expected-one-of-t-r-n-input-filter-output-at-line-1-column-1-byte-1/255210/4 "2020-12-15T11:56:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
