# Logstash does not start after upgrade from 6.1.2 to 6.4.0

**URL:** https://discuss.elastic.co/t/logstash-does-not-start-after-upgrade-from-6-1-2-to-6-4-0/148478
**Category:** Logstash
**Created:** [September 13, 2018, 4:04pm UTC](https://discuss.elastic.co/t/logstash-does-not-start-after-upgrade-from-6-1-2-to-6-4-0/148478 "2018-09-13T16:04:45Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![t\_kauf](https://avatars.discourse-cdn.com/v4/letter/t/bbe5ce/32.png) [@t\_kauf](https://discuss.elastic.co/u/t_kauf)
#### Post date: [September 13, 2018, 4:04pm UTC](https://discuss.elastic.co/t/logstash-does-not-start-after-upgrade-from-6-1-2-to-6-4-0/148478/1 "2018-09-13T16:04:45Z")

</div>

Hi,  
today I upgraded my Elasticstack from Version 6.1.2 to 6.4.0.  
Since then Logstash does not start correctly anymore.

I have pasted the logs / output here: [https://paste.fedoraproject.org/paste/IR-6sdrXbmRgKgj5QNRbGw](https://paste.fedoraproject.org/paste/IR-6sdrXbmRgKgj5QNRbGw)  
because it exceeds the 7000 character limit of forum posts.

But unfortunately I cannot interpret that error and have no idea what the log is trying to tell me.  
Has anybody seen that error and knows a fix or can give me hints or tips how to further investigate / narrow down the problem?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 11, 2018, 4:04pm UTC](https://discuss.elastic.co/t/logstash-does-not-start-after-upgrade-from-6-1-2-to-6-4-0/148478/2 "2018-10-11T16:04:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
