# Logstash doesn't receive any logs from filebeat

**URL:** https://discuss.elastic.co/t/logstash-doesnt-receive-any-logs-from-filebeat/140796
**Category:** Logstash
**Created:** [July 19, 2018, 7:18pm UTC](https://discuss.elastic.co/t/logstash-doesnt-receive-any-logs-from-filebeat/140796 "2018-07-19T19:18:14Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Ferdous\_Shibly](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ferdous_shibly/32/23470_2.png) [@Ferdous\_Shibly](https://discuss.elastic.co/u/Ferdous_Shibly)
#### Post date: [July 19, 2018, 7:18pm UTC](https://discuss.elastic.co/t/logstash-doesnt-receive-any-logs-from-filebeat/140796/1 "2018-07-19T19:18:15Z")

</div>

We are getting the following error message in Filebeat

> | 2018-07-19T18:46:18.832Z | ERROR | logstash/async.go:235 | Failed to publish events caused by: write tcp 172.17.0.2:42194-\>10.14.86.242:9191: write: connection reset by peer |
> | --- | --- | --- | --- |
> | 2018-07-19T18:46:19.833Z | ERROR | pipeline/output.go:92 | Failed to publish events: write tcp 172.17.0.2:42194-\>10.14.86.242:9191: write: connection reset by peer |

But the connectivity is OK.

> root@95eff4da9e80:/etc/filebeat# telnet 10.14.86.242 9191  
> Trying 10.14.86.242...  
> Connected to 10.14.86.242  
> Escape character is '^]'.  
> ^]  
> telnet\> quit  
> Connection closed.

Here is the filebeat configuration

```
filebeat.inputs:
- type: log
  enabled: true
  paths:
    - /usr/src/logs/*.json
  json.message_key: log
  json.keys_under_root: true
  json.add_error_key: true
  multiline.pattern: '^\s'
  multiline.match: after
  document_type: flow-logs
  tail_files: true

filebeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false

setup.template.settings:
  index.number_of_shards: 3

output.logstash:
  hosts: ["10.14.86.242:9191"]

```

And here is the logstash configuration:

```
input{
  beats {
    host => "0.0.0.0"
    port => 9191
    client_inactivity_timeout => 86400
  }
}

output {

    amazon_es {
      hosts => ["<aws-es>"]
      region => "<aws-region>"
      index => "flow-logs-%{+YYYY.MM.dd}"
      codec => "json"
    }

}

/usr/share/logstash/bin/logstash-plugin list --verbose beats
logstash-input-beats (5.1.0)

```

How can I resolve the issue?

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [July 22, 2018, 6:12pm UTC](https://discuss.elastic.co/t/logstash-doesnt-receive-any-logs-from-filebeat/140796/2 "2018-07-22T18:12:40Z")

</div>

Have you looked in the Logstash log? It might tell you why it's closing the connections.

---

<div class="post-metadata">

### Author: ![Ferdous\_Shibly](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ferdous_shibly/32/23470_2.png) [@Ferdous\_Shibly](https://discuss.elastic.co/u/Ferdous_Shibly)
#### Post date: [July 23, 2018, 4:21pm UTC](https://discuss.elastic.co/t/logstash-doesnt-receive-any-logs-from-filebeat/140796/3 "2018-07-23T16:21:06Z")

</div>

I don't see any error messages in logstash even with stdout or debug logging.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 20, 2018, 4:21pm UTC](https://discuss.elastic.co/t/logstash-doesnt-receive-any-logs-from-filebeat/140796/4 "2018-08-20T16:21:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
