# Logstash doesnt start after upgrade to 6.8.13 (from 6.2.3)

**URL:** https://discuss.elastic.co/t/logstash-doesnt-start-after-upgrade-to-6-8-13-from-6-2-3/260599
**Category:** Logstash
**Created:** [January 9, 2021, 10:43am UTC](https://discuss.elastic.co/t/logstash-doesnt-start-after-upgrade-to-6-8-13-from-6-2-3/260599 "2021-01-09T10:43:56Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![cfu](https://avatars.discourse-cdn.com/v4/letter/c/3e96dc/32.png) [@cfu](https://discuss.elastic.co/u/cfu)
#### Post date: [January 9, 2021, 10:43am UTC](https://discuss.elastic.co/t/logstash-doesnt-start-after-upgrade-to-6-8-13-from-6-2-3/260599/1 "2021-01-09T10:43:57Z")

</div>

After upgrading logstash 6.3.2 to 6.8.13 it doesn´t start. Looking into the log file shows:

```
[2021-01-09T11:24:12,770][DEBUG][logstash.modules.scaffold] Found module {:module_name=>"fb_apache", :directory=>"/products/elk/logstash/modules/fb_apache/configuration"}
[2021-01-09T11:24:12,770][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"fb_apache", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0x62ae5180 @directory="/products/elk/logstash/modules/fb_apache/configuration", @module_name="fb_apache", @kibana_version_parts=["6", "0", "0"]>}
[2021-01-09T11:24:12,800][FATAL][logstash.runner] An unexpected error occurred! {:error=>#<NameError: uninitialized constant LibC::FFI>, :backtrace=>["org/jruby/RubyModule.java:3742:in `const_missing'", "/products/elk/logstash-6.8.13/logstash-core/lib/logstash/util/prctl.rb:4:in `<module:LibC>'", "/products/elk/logstash-6.8.13/logstash-core/lib/logstash/util/prctl.rb:2:in `<main>'", "org/jruby/RubyKernel.java:987:in `require'", "/products/elk/logstash-6.8.13/vendor/bundle/jruby/2.5.0/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'", "/products/elk/logstash-6.8.13/logstash-core/lib/logstash/util.rb:1:in `(root)'", "/products/elk/logstash-6.8.13/logstash-core/lib/logstash/util.rb:21:in `set_thread_name'", "/products/elk/logstash-6.8.13/logstash-core/lib/logstash/runner.rb:306:in `execute'", "/products/elk/logstash-6.8.13/vendor/bundle/jruby/2.5.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/products/elk/logstash-6.8.13/logstash-core/lib/logstash/runner.rb:237:in `run'", "/products/elk/logstash/lib/bootstrap/environment.rb:73:in `<main>'"]}
[2021-01-09T11:24:12,802][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit 

```

I copied the configuration from the 6.3.2 version to 6.8.13 version and changed the key words according the 6.8.13. guide...  
I thougth upgrading minor versions should be an easy task.. ☹

---

<div class="post-metadata">

### Author: ![Wolfram\_Haussig](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wolfram_haussig/32/70528_2.png) [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)
#### Post date: [January 11, 2021, 6:39am UTC](https://discuss.elastic.co/t/logstash-doesnt-start-after-upgrade-to-6-8-13-from-6-2-3/260599/2 "2021-01-11T06:39:26Z")

</div>

Hi,

There is an open issue on github which is not yet solved but maybe you could add a comment there:

> <https://github.com/elastic/logstash/issues/12175>
>
> Version: 6.8.11
> Operating System: Linux, maybe MacOSX
> Steps to Reproduce:
> run docker with Dockerfile
> FROM logstash:6.8.11
> USER logstash
> RUN ln -s /usr/share/logstash /tmp/log
> RUN echo "input { stdin...

Best regards  
Wolfram

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 8, 2021, 6:39am UTC](https://discuss.elastic.co/t/logstash-doesnt-start-after-upgrade-to-6-8-13-from-6-2-3/260599/3 "2021-02-08T06:39:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
