# Logstash Elasticsearch output configuration

**URL:** https://discuss.elastic.co/t/logstash-elasticsearch-output-configuration/25122
**Category:** Logstash
**Created:** [July 8, 2015, 7:44am UTC](https://discuss.elastic.co/t/logstash-elasticsearch-output-configuration/25122 "2015-07-08T07:44:43Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Nicolas\_Guyomar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nicolas_guyomar/32/10124_2.png) [@Nicolas\_Guyomar](https://discuss.elastic.co/u/Nicolas_Guyomar)
#### Post date: [July 8, 2015, 7:44am UTC](https://discuss.elastic.co/t/logstash-elasticsearch-output-configuration/25122/1 "2015-07-08T07:44:43Z")

</div>

Hi everyone,

I've just upgraded from logstash 1.4.2 to 1.5.2.  
Everything works fine using "node" protocol to send messages to elasticsearch using bulk API  
I have no iptables on my elasticsearch.  
MulticastDiscovery is disable on my elasticsearch instance, that's why I'm setting the host parameter as stated in the documentation

I do not understand the following error message, as I think I should see my elasticsearch hostname between the error bracket

```
{:timestamp=>"2015-07-08T09:31:09.364000+0200", :message=>"Got error to send bulk of actions: None of the configured nodes are available: []", :level=>:error}

```

Here is my output configuration

```
output {
        elasticsearch {
                host => ["lberbela01"]
                cluster => "lbelasticsearchcluster"
                manage_template => false
                protocol => "transport"
        }
}

```

I need to use transport protocol because I'm planning to install shield

Thanks for any help

---

<div class="post-metadata">

### Author: ![Nicolas\_Guyomar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nicolas_guyomar/32/10124_2.png) [@Nicolas\_Guyomar](https://discuss.elastic.co/u/Nicolas_Guyomar)
#### Post date: [July 8, 2015, 8:14am UTC](https://discuss.elastic.co/t/logstash-elasticsearch-output-configuration/25122/2 "2015-07-08T08:14:51Z")

</div>

Please consider this problem solved, our elasticsearch team upgraded to elasticsearch 1.6 and we missed some configuration

Everything is back to normal

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 5:35am UTC](https://discuss.elastic.co/t/logstash-elasticsearch-output-configuration/25122/3 "2017-07-06T05:35:19Z")

</div>


