# Logstash Error: Beats input: the pipeline is blocked, temporary refusing new connection

**URL:** <https://discuss.elastic.co/t/logstash-error-beats-input-the-pipeline-is-blocked-temporary-refusing-new-connection/52929>\
**Category:** Logstash\
**Created:** [June 15, 2016, 11:33pm UTC](https://discuss.elastic.co/t/logstash-error-beats-input-the-pipeline-is-blocked-temporary-refusing-new-connection/52929 "2016-06-15T23:33:23Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mike\_Wurtz](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@Mike\_Wurtz](https://discuss.elastic.co/u/Mike_Wurtz)\
**Post date:** [June 15, 2016, 11:33pm UTC](https://discuss.elastic.co/t/logstash-error-beats-input-the-pipeline-is-blocked-temporary-refusing-new-connection/52929/1 "2016-06-15T23:33:23Z")

</div>

After pointing 8 or so filebeat agents to my logstash server, I'm getting this message in the logstash log:  
`Beats input: the pipeline is blocked, temporary refusing new connection.`

What is the cause of this error?

At first I assumed it was because I don't have a redis queue in the stack.. But from everything I've read, I'm very confused as to if I should use redis between Filebeat or not.

Is this error because I need a Redis message queue, or something else?

Pasted below are my filebeat inputs and ES outputs:

```auto
input {
  beats {
    port => 5044
    type => "logs"
    ssl => true
    ssl_certificate => "/etc/pki/tls/certs/somecert.crt"
    ssl_key => "/etc/pki/tls/private/somecert.key"
    congestion_threshold => "40"
  }
}

output {
  elasticsearch {
    hosts => ["my_es_client_node_lb:9200"]
    user => logstash
    password => my_pw
  }

  stdout { codec => rubydebug }
}

```

---

<div class="post-metadata">

**Author:** ![Mike\_Wurtz](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@Mike\_Wurtz](https://discuss.elastic.co/u/Mike_Wurtz)\
**Post date:** [June 16, 2016, 1:01am UTC](https://discuss.elastic.co/t/logstash-error-beats-input-the-pipeline-is-blocked-temporary-refusing-new-connection/52929/2 "2016-06-16T01:01:58Z")

</div>

FYI I've resolved my issue it looks like.. By condensing all of my pipleline config into one file, I seemed to have silienced the error I was getting before..

I'm indexing up to 900 events per second, from filebeat to logstash directly, and logstash isn't complaining at all.

---

<div class="post-metadata">

**Author:** ![RustuGurkan](https://avatars.discourse-cdn.com/v4/letter/r/a183cd/32.png) [@RustuGurkan](https://discuss.elastic.co/u/RustuGurkan)\
**Post date:** [May 11, 2017, 2:37pm UTC](https://discuss.elastic.co/t/logstash-error-beats-input-the-pipeline-is-blocked-temporary-refusing-new-connection/52929/3 "2017-05-11T14:37:48Z")

</div>

Hi @Mike_Wurtz could you please share you're config I'm new to ELK don't know what to do

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:26am UTC](https://discuss.elastic.co/t/logstash-error-beats-input-the-pipeline-is-blocked-temporary-refusing-new-connection/52929/4 "2017-07-06T04:26:40Z")

</div>


