# Logstash error 'configtest'

**URL:** <https://discuss.elastic.co/t/logstash-error-configtest/46232>\
**Category:** Logstash\
**Created:** [April 4, 2016, 11:59am UTC](https://discuss.elastic.co/t/logstash-error-configtest/46232 "2016-04-04T11:59:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ironbeast](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Post date:** [April 4, 2016, 11:59am UTC](https://discuss.elastic.co/t/logstash-error-configtest/46232/1 "2016-04-04T11:59:23Z")

</div>

Dear all,  
After updating to the latest logstash version (logstash-2.3.0-1.noarch), I can't start logstash anymore as a service...  
When I run 'service logstash configtest' I get:  
An unexpected error occurred! {:error=\>#\<NoMethodError: undefined method `config_valid?' for LogStash::Pipeline:Class>, :class=>"NoMethodError", :backtrace=>["/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.0-java/lib/logstash/agent.rb:169:in`execute'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.0-java/lib/logstash/runner.rb:94:in `run'", "org/jruby/RubyProc.java:281:in`call'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.0-java/lib/logstash/runner.rb:99:in `run'", "org/jruby/RubyProc.java:281:in`call'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/stud-0.0.22/lib/stud/task.rb:24:in `initialize'"], :level=\>:warn}

With the service logstash start it stops immediatly...

But when I try to run logstash straight from the binary (/opt/logstash/bin/logstash) it works perfectly...

I found someting for /etc/ld.so.conf.d/java.conf. I Added the path to the [libjli.so](http://libjli.so) library. (/usr/java/default/jre/lib/amd64/jli/), but this didn't seem to help either... Still gives the same error for the configtest...

Any ideas?

---

<div class="post-metadata">

**Author:** ![ironbeast](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Post date:** [April 4, 2016, 12:05pm UTC](https://discuss.elastic.co/t/logstash-error-configtest/46232/2 "2016-04-04T12:05:50Z")

</div>

Same as [Logstash upgrade from 2.2 to 2.3 failed](https://discuss.elastic.co/t/logstash-upgrade-from-2-2-to-2-3-failed/45887/8)

Sorry... [Solved]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:04am UTC](https://discuss.elastic.co/t/logstash-error-configtest/46232/3 "2017-07-06T05:04:04Z")

</div>


