# Logstash Error : Error Registering Plugin

**URL:** <https://discuss.elastic.co/t/logstash-error-error-registering-plugin/128824>\
**Category:** Logstash\
**Created:** [April 20, 2018, 8:07am UTC](https://discuss.elastic.co/t/logstash-error-error-registering-plugin/128824 "2018-04-20T08:07:19Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Saurav\_Vasudev](https://avatars.discourse-cdn.com/v4/letter/s/ce7236/32.png) [@Saurav\_Vasudev](https://discuss.elastic.co/u/Saurav_Vasudev)\
**Post date:** [April 20, 2018, 8:07am UTC](https://discuss.elastic.co/t/logstash-error-error-registering-plugin/128824/1 "2018-04-20T08:07:19Z")

</div>

I am getting the following error on running Logstash :  
[2018-04-20T13:18:02,661][ERROR][logstash.pipeline] Error registering plugin {:pipeline\_id=\>"main", :plugin=\>"#\<LogStash::OutputDelegator:0x4bf9ba3d @namespaced\_metric  
=#\<LogStash::Instrument::NamespacedMetric:0x5db26838 @metric=#\<LogStash::Instrument::Metric:0x35b10995 @collector=#\<LogStash::Instrument::Collector:0x26244967 @agent=nil, @met  
ric\_store=#\<LogStash::Instrument::MetricStore:0x208a27cc @store=#\<Concurrent:🗺0x00000000000fb0 entries=3 default\_proc=nil\>, @structured\_lookup\_mutex=#Mutex:0x571c2dc7, @  
fast\_lookup=#\<Concurrent:🗺0x00000000000fb4 entries=58 default\_proc=nil\>\>\>\>, @namespace\_name=[:stats, :pipelines, :main, :plugins, :outputs, :cbbe61e4681dee634251665643d028  
ec31f4592a3d0004adb8226c5a9559bdf0]\>, @metric=#\<LogStash::Instrument::NamespacedMetric:0x73f9b529 @metric=#\<LogStash::Instrument::Metric:0x35b10995 @collector=#\<LogStash::Inst  
rument::Collector:0x26244967 @agent=nil, @metric\_store=#\<LogStash::Instrument::MetricStore:0x208a27cc @store=#\<Concurrent:🗺0x00000000000fb0 entries=3 default\_proc=nil\>, @s  
tructured\_lookup\_mutex=#Mutex:0x571c2dc7, @fast\_lookup=#\<Concurrent:🗺0x00000000000fb4 entries=58 default\_proc=nil\>\>\>\>, @namespace\_name=[:stats, :pipelines, :main, :plugi  
ns, :outputs]\>, @out\_counter=org.jruby.proxy.org.logstash.instrument.metrics.counter.LongCounter$Proxy2 - name: out value:0, @strategy=#\<LogStash::OutputDelegatorStrategies::  
Shared:0x2f6db44f @output=\<LogStash::Outputs::Elasticsearch hosts=\>[[//localhost:9200](https://localhost:9200)], id=\>"cbbe61e4681dee634251665643d028ec31f4592a3d0004adb8226c5a9559bdf0", enable\_metric=

> true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_e42ae012-b740-4a57-b0a1-3531b8de291e", enable\_metric=\>true, charset=\>"UTF-8"\>, workers=\>1, index=\>"logstash-%{+YYYY.MM.d  
> d}", manage\_template=\>true, template\_name=\>"logstash", template\_overwrite=\>false, doc\_as\_upsert=\>false, script\_type=\>"inline", script\_lang=\>"painless", script\_var\_name=  
> "event", scripted\_upsert=\>false, retry\_initial\_interval=\>2, retry\_max\_interval=\>64, retry\_on\_conflict=\>1, action=\>"index", ssl\_certificate\_verification=\>true, sniffing=\>f  
> alse, sniffing\_delay=\>5, timeout=\>60, pool\_max=\>1000, pool\_max\_per\_route=\>100, resurrect\_delay=\>5, validate\_after\_inactivity=\>10000, http\_compression=\>false, metric=\>#\<LogStas  
> h::Instrument::NamespacedMetric:0x5db26838 @metric=#\<LogStash::Instrument::Metric:0x35b10995 @collector=#\<LogStash::Instrument::Collector:0x26244967 @agent=nil, @metric\_store=  
> #\<LogStash::Instrument::MetricStore:0x208a27cc @store=#\<Concurrent:🗺0x00000000000fb0 entries=3 default\_proc=nil\>, @structured\_lookup\_mutex=#Mutex:0x571c2dc7, @fast\_looku  
> p=#\<Concurrent:🗺0x00000000000fb4 entries=58 default\_proc=nil\>\>\>\>, @namespace\_name=[:stats, :pipelines, :main, :plugins, :outputs, :cbbe61e4681dee634251665643d028ec31f4592a  
> 3d0004adb8226c5a9559bdf0]\>\>\>, @in\_counter=org.jruby.proxy.org.logstash.instrument.metrics.counter.LongCounter$Proxy2 - name: in value:0, @id="cbbe61e4681dee634251665643d028e  
> c31f4592a3d0004adb8226c5a9559bdf0", @time\_metric=org.jruby.proxy.org.logstash.instrument.metrics.counter.LongCounter$Proxy2 - name: duration\_in\_millis value:0, @metric\_event  
> s=#\<LogStash::Instrument::NamespacedMetric:0x47f9f1b1 @metric=#\<LogStash::Instrument::Metric:0x35b10995 @collector=#\<LogStash::Instrument::Collector:0x26244967 @agent=nil, @me  
> tric\_store=#\<LogStash::Instrument::MetricStore:0x208a27cc @store=#\<Concurrent:🗺0x00000000000fb0 entries=3 default\_proc=nil\>, @structured\_lookup\_mutex=#Mutex:0x571c2dc7,  
> @fast\_lookup=#\<Concurrent:🗺0x00000000000fb4 entries=58 default\_proc=nil\>\>\>\>, @namespace\_name=[:stats, :pipelines, :main, :plugins, :outputs, :cbbe61e4681dee634251665643d02  
> 8ec31f4592a3d0004adb8226c5a9559bdf0, :events]\>, @output\_class=LogStash::Outputs::Elasticsearch\>", :error=\>"SSLConnectionSocketFactory not found in packages org.apache.http.cli  
> ent.methods, org.apache.http.client.entity, org.apache.http.client.config, org.apache.http.config, org.apache.http.conn.socket, org.apache.http.impl, org.apache.http.impl.clie  
> nt, org.apache.http.impl.conn, org.apache.http.impl.auth, org.apache.http.entity, org.apache.http.message, org.apache.http.params, org.apache.http.protocol, org.apache.http.au  
> th, java.util.concurrent, org.apache.http.client.protocol, org.apache.http.conn.ssl, java.security.cert, java.security.spec, java.security, org.apache.http.client.utils; last  
> error: cannot load Java class org.apache.http.client.utils.SSLConnectionSocketFactory", :thread=\>"#\<Thread:0x2e6ce700 run\>"}  
> [2018-04-20T13:18:02,676][ERROR][logstash.pipeline] Pipeline aborted due to error {:pipeline\_id=\>"main", :exception=\>#\<NameError: SSLConnectionSocketFactory not found  
> in packages org.apache.http.client.methods, org.apache.http.client.entity, org.apache.http.client.config, org.apache.http.config, org.apache.http.conn.socket, org.apache.http.  
> impl, org.apache.http.impl.client, org.apache.http.impl.conn, org.apache.http.impl.auth, org.apache.http.entity, org.apache.http.message, org.apache.http.params, org.apache.ht  
> tp.protocol, org.apache.http.auth, java.util.concurrent, org.apache.http.client.protocol, org.apache.http.conn.ssl, java.security.cert, java.security.spec, java.security, org.  
> apache.http.client.utils; last error: cannot load Java class org.apache.http.client.utils.SSLConnectionSocketFactory\>, :backtrace=\>["uri:classloader:/jruby/java/core\_ext/modul  
> e.rb:45:in `const_missing'", "D:/Userfiles/svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/manticore-0.6.1-java/lib/manticore/client.rb:603:in `ssl\_socket\_facto  
> ry\_from\_options'", "D:/Userfiles/svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/manticore-0.6.1-java/lib/manticore/client.rb:394:in `pool\_builder'", "D:/Userfi  
> les/svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/manticore-0.6.1-java/lib/manticore/client.rb:402:in `pool'", "D:/Userfiles/svasudev/Desktop/logstash-6.2.4/v  
> endor/bundle/jruby/2.3.0/gems/manticore-0.6.1-java/lib/manticore/client.rb:208:in `initialize'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/l  
> ogstash-output-elasticsearch-9.1.1-java/lib/logstash/outputs/elasticsearch/http\_client/manticore\_adapter.rb:26:in `initialize'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/  
> vendor/bundle/jruby/2.3.0/gems/logstash-output-elasticsearch-9.1.1-java/lib/logstash/outputs/elasticsearch/http\_client.rb:279:in `build\_adapter'", ......................

---

<div class="post-metadata">

**Author:** ![Saurav\_Vasudev](https://avatars.discourse-cdn.com/v4/letter/s/ce7236/32.png) [@Saurav\_Vasudev](https://discuss.elastic.co/u/Saurav_Vasudev)\
**Post date:** [April 20, 2018, 8:08am UTC](https://discuss.elastic.co/t/logstash-error-error-registering-plugin/128824/2 "2018-04-20T08:08:11Z")

</div>

coninued error:  
"d:/Userfiles/svasudev/Deskt  
op/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/logstash-output-elasticsearch-9.1.1-java/lib/logstash/outputs/elasticsearch/http\_client.rb:283:in `build_pool'", "d:/Userfiles /svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/logstash-output-elasticsearch-9.1.1-java/lib/logstash/outputs/elasticsearch/http_client.rb:63:in`initialize'",  
"d:/Userfiles/svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/logstash-output-elasticsearch-9.1.1-java/lib/logstash/outputs/elasticsearch/http\_client\_builder.r  
b:102:in `create_http_client'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/logstash-output-elasticsearch-9.1.1-java/lib/logstash/outputs/elas ticsearch/http_client_builder.rb:98:in`build'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/logstash-output-elasticsearch-9.1.1-java/lib/logs  
tash/outputs/elasticsearch.rb:231:in `build_client'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/vendor/bundle/jruby/2.3.0/gems/logstash-output-elasticsearch-9.1.1-java/lib /logstash/outputs/elasticsearch/common.rb:24:in`register'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/logstash-core/lib/logstash/output\_delegator\_strategies/shared.rb:9:i  
n `register'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/logstash-core/lib/logstash/output_delegator.rb:42:in`register'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/lo  
gstash-core/lib/logstash/pipeline.rb:342:in `register_plugin'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/logstash-core/lib/logstash/pipeline.rb:353:in`block in register\_  
plugins'", "org/jruby/RubyArray.java:1734:in `each'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/logstash-core/lib/logstash/pipeline.rb:353:in`register\_plugins'", "d:/User  
files/svasudev/Desktop/logstash-6.2.4/logstash-core/lib/logstash/pipeline.rb:730:in `maybe_setup_out_plugins'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/logstash-core/lib /logstash/pipeline.rb:363:in`start\_workers'", "d:/Userfiles/svasudev/Desktop/logstash-6.2.4/logstash-core/lib/logstash/pipeline.rb:290:in `run'", "d:/Userfiles/svasudev/Deskt op/logstash-6.2.4/logstash-core/lib/logstash/pipeline.rb:250:in`block in start'"], :thread=\>"#\<Thread:0x2e6ce700 run\>"}  
[2018-04-20T13:18:02,679][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not ex  
ecute action: LogStash::PipelineAction::Create/pipeline\_id:main, action\_result: false", :backtrace=\>nil}

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 18, 2018, 8:08am UTC](https://discuss.elastic.co/t/logstash-error-error-registering-plugin/128824/3 "2018-05-18T08:08:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
