# Ошибка в логах Logstash:\[ERROR\]\[logstash.outputs.elasticsearch\] An unknown error occurred sending a bulk request to Elasticsearch. We will retry indefinitely {:error\_message=\>"Broken pipe (Write failed)

**URL:** <https://discuss.elastic.co/t/logstash-error-logstash-outputs-elasticsearch-an-unknown-error-occurred-sending-a-bulk-request-to-elasticsearch-we-will-retry-indefinitely-error-message-broken-pipe-write-failed/210741>\
**Category:** Вопросы на русском языке\
**Created:** [December 5, 2019, 4:12pm UTC](https://discuss.elastic.co/t/logstash-error-logstash-outputs-elasticsearch-an-unknown-error-occurred-sending-a-bulk-request-to-elasticsearch-we-will-retry-indefinitely-error-message-broken-pipe-write-failed/210741 "2019-12-05T16:12:40Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![111229](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/111229/32/56578_2.png) [@111229](https://discuss.elastic.co/u/111229)\
**Post date:** [December 5, 2019, 4:12pm UTC](https://discuss.elastic.co/t/logstash-error-logstash-outputs-elasticsearch-an-unknown-error-occurred-sending-a-bulk-request-to-elasticsearch-we-will-retry-indefinitely-error-message-broken-pipe-write-failed/210741/1 "2019-12-05T16:12:40Z")

</div>

Коллеги, приветствую!

Помогите, пожалуйста.  
Кто-нибудь сталкивался с ошибкой в logstash Broken pipe (Write failed)?  
Суть всё работало замечательно, бед не знали и в какой-то день просто валом посыпались ошибки ниже.  
Подскажите, что они означают и что делать?  
Заранее спасибо!

```auto
[2019-12-05T19:11:02,036][ERROR][logstash.outputs.elasticsearch] An unknown error occurred sending a bulk request to Elasticsearch. We will retry indefinitely {:error_message=>"Broken pipe (Write failed)", :error_class=>"Manticore::UnknownException", :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:37:in `block in initialize'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:79:in `call'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client/manticore_adapter.rb:74:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:291:in `perform_request_to_url'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:278:in `block in perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:373:in `with_connection'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:277:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:285:in `block in Pool'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client.rb:143:in `bulk_send'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client.rb:123:in `block in bulk'", "org/jruby/RubyArray.java:1792:in `each'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http_client.rb:117:in `bulk'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/common.rb:296:in `safe_bulk'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/common.rb:201:in `submit'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/common.rb:169:in `retrying_submit'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/common.rb:38:in `multi_receive'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:118:in `multi_receive'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:101:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:239:in `block in start_workers'"]}

```

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [December 5, 2019, 4:16pm UTC](https://discuss.elastic.co/t/logstash-error-logstash-outputs-elasticsearch-an-unknown-error-occurred-sending-a-bulk-request-to-elasticsearch-we-will-retry-indefinitely-error-message-broken-pipe-write-failed/210741/2 "2019-12-05T16:16:49Z")

</div>

В логах elasticsearch что-нибудь есть? Если нет - то надо перехватить трафик от elasticsearch (wireshark-ом, например) и посмотреть, что он обратно посылает.

---

<div class="post-metadata">

**Author:** ![111229](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/111229/32/56578_2.png) [@111229](https://discuss.elastic.co/u/111229)\
**Post date:** [December 5, 2019, 4:30pm UTC](https://discuss.elastic.co/t/logstash-error-logstash-outputs-elasticsearch-an-unknown-error-occurred-sending-a-bulk-request-to-elasticsearch-we-will-retry-indefinitely-error-message-broken-pipe-write-failed/210741/3 "2019-12-05T16:30:43Z")

</div>

Игорь, два момента.  
Первый: мы отключили swap на дата-нодах. Может ли это быть причиной?  
Второе: у нас 8 нод (чуть позже посмотрю на всех), но выборочный анализ показал, что регистрация в логах Logstash не порождает хоть какую-то ошибку на data-нодах.

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [December 5, 2019, 4:34pm UTC](https://discuss.elastic.co/t/logstash-error-logstash-outputs-elasticsearch-an-unknown-error-occurred-sending-a-bulk-request-to-elasticsearch-we-will-retry-indefinitely-error-message-broken-pipe-write-failed/210741/4 "2019-12-05T16:34:54Z")

</div>

Зачем гадать, если можно посмотреть конкретную ошибку?

---

<div class="post-metadata">

**Author:** ![111229](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/111229/32/56578_2.png) [@111229](https://discuss.elastic.co/u/111229)\
**Post date:** [December 6, 2019, 7:32am UTC](https://discuss.elastic.co/t/logstash-error-logstash-outputs-elasticsearch-an-unknown-error-occurred-sending-a-bulk-request-to-elasticsearch-we-will-retry-indefinitely-error-message-broken-pipe-write-failed/210741/5 "2019-12-06T07:32:47Z")

</div>

Проблема решилась включением grock в одном из pipeline, по которому прилетает 200 000 событий в минуту.  
Понять почему пока не удается. В логах дата-нод чисто, а с wireshark(ом) мы по ка что не подружились

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 3, 2020, 7:33am UTC](https://discuss.elastic.co/t/logstash-error-logstash-outputs-elasticsearch-an-unknown-error-occurred-sending-a-bulk-request-to-elasticsearch-we-will-retry-indefinitely-error-message-broken-pipe-write-failed/210741/6 "2020-01-03T07:33:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
