# Logstash: ERROR Manticore::ClientProtocolException

**URL:** https://discuss.elastic.co/t/logstash-error-manticore-clientprotocolexception/234481
**Category:** Logstash
**Created:** [May 27, 2020, 8:00am UTC](https://discuss.elastic.co/t/logstash-error-manticore-clientprotocolexception/234481 "2020-05-27T08:00:33Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![aannee](https://avatars.discourse-cdn.com/v4/letter/a/87869e/32.png) [@aannee](https://discuss.elastic.co/u/aannee)
#### Post date: [May 27, 2020, 8:00am UTC](https://discuss.elastic.co/t/logstash-error-manticore-clientprotocolexception/234481/1 "2020-05-27T08:00:33Z")

</div>

Hi, I'm getting this error when I'm running my logstash pipeline. Is it because I have no valid ssl cert?

Here's my conf

```auto
filter {
        elasticsearch {
                ssl => false
                hosts => ["localhost:9200"]
                user => "username"
                password => "password"
                index => "myindex"
                query => "Status:started"
        }

}
output {
  stdout { codec => rubydebug }
}

```

Here's the error

```auto
[2020-05-27T03:56:34,067][ERROR][logstash.javapipeline] Pipeline aborted due to error {:pipeline_id=>"main", :exception=>#<Manticore::ClientProtocolException: localhost:9200 failed to respond>, :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:37:in `block in initialize'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:79:in `call'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:274:in `call_once'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:158:in `code'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/elasticsearch-transport-5.0.5/lib/elasticsearch/transport/transport/http/manticore.rb:84:in `block in perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/elasticsearch-transport-5.0.5/lib/elasticsearch/transport/transport/base.rb:262:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/elasticsearch-transport-5.0.5/lib/elasticsearch/transport/transport/http/manticore.rb:67:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/elasticsearch-transport-5.0.5/lib/elasticsearch/transport/client.rb:131:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/elasticsearch-api-5.0.5/lib/elasticsearch/api/actions/ping.rb:20:in `ping'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-filter-elasticsearch-3.6.0/lib/logstash/filters/elasticsearch.rb:192:in `test_connection!'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-filter-elasticsearch-3.6.0/lib/logstash/filters/elasticsearch.rb:74:in `register'", "org/logstash/config/ir/compiler/AbstractFilterDelegatorExt.java:56:in `register'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:191:in `block in register_plugins'", "org/jruby/RubyArray.java:1792:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:190:in `register_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:446:in `maybe_setup_out_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:203:in `start_workers'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:145:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:104:in `block in start'"], :thread=>"#<Thread:0x18fe90e8 run>"}
[2020-05-27T03:56:34,093][ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[2020-05-27T03:56:34,353][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2020-05-27T03:56:39,455][INFO][logstash.runner] Logstash shut down.

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 24, 2020, 8:09am UTC](https://discuss.elastic.co/t/logstash-error-manticore-clientprotocolexception/234481/2 "2020-06-24T08:09:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
