# Logstash : error No configuration found in the configured sources

**URL:** <https://discuss.elastic.co/t/logstash-error-no-configuration-found-in-the-configured-sources/178624>\
**Category:** Logstash\
**Created:** [April 26, 2019, 10:23am UTC](https://discuss.elastic.co/t/logstash-error-no-configuration-found-in-the-configured-sources/178624 "2019-04-26T10:23:37Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![medaly\_ahmed](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/medaly_ahmed/32/44262_2.png) [@medaly\_ahmed](https://discuss.elastic.co/u/medaly_ahmed)\
**Post date:** [April 26, 2019, 10:23am UTC](https://discuss.elastic.co/t/logstash-error-no-configuration-found-in-the-configured-sources/178624/1 "2019-04-26T10:23:37Z")

</div>

I install elasticsearch, kibana and logstash on ubuntu  
but when i try to load the file i find an error:

```
bin/logstash -f medicacno_montant.conf
Sending Logstash logs to /home/ubuntu/elk/logstash-7.0.0/logs which is now configured via log4j2.properties
[2019-04-26T06:12:59,185][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2019-04-26T06:12:59,853][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.0.0"}
[2019-04-26T06:13:01,398][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=>"/home/ubuntu/elk/logstash-7.0.0/medicacno_montant.conf"}
[2019-04-26T06:13:01,411][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2019-04-26T06:13:02,093][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2019-04-26T06:13:06,726][INFO][logstash.runner] Logstash shut down.

```

my config file :

```
input {
 jdbc {
    jdbc_driver_library => "C:\logstash-6.7.1\bin\mysql-connector-java-5.1.15-bin.jar"
    jdbc_driver_class => "com.mysql.jdbc.Driver"
    jdbc_connection_string => "jdbc:mysql://localhost:3306/medicacno?useTimezone=true&useLegacyDatetimeCode=false&serverTimezone=UTC"
    jdbc_user => "medaly"
	jdbc_password => "123456"
	statement => "SELECT montant , nom , date FROM recu INNER JOIN service on recu.idService=service.id "
  }
}

output {
  elasticsearch { hosts => ["localhost:9200"] index => "medicacno_montant" }
  stdout { codec => rubydebug }
}
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 24, 2019, 10:23am UTC](https://discuss.elastic.co/t/logstash-error-no-configuration-found-in-the-configured-sources/178624/2 "2019-05-24T10:23:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
