# Logstash Error start error

**URL:** <https://discuss.elastic.co/t/logstash-error-start-error/177749>\
**Category:** Logstash\
**Created:** [April 21, 2019, 12:01pm UTC](https://discuss.elastic.co/t/logstash-error-start-error/177749 "2019-04-21T12:01:25Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![MikoMan](https://avatars.discourse-cdn.com/v4/letter/m/fbc32d/32.png) [@MikoMan](https://discuss.elastic.co/u/MikoMan)\
**Post date:** [April 21, 2019, 12:01pm UTC](https://discuss.elastic.co/t/logstash-error-start-error/177749/1 "2019-04-21T12:01:25Z")

</div>

Hi there,

Just tried to config logstash to work with elatstich and i got some problems.  
running on same linux machine i got :  
elasticsearch 7  
kibana 7  
logstash 7

while trying to start logstash i got this error:

[2019-04-21T14:59:30,352][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.0.0"}  
[2019-04-21T14:59:41,587][INFO][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://10.70.25.150:9200/](http://10.70.25.150:9200/)]}}  
[2019-04-21T14:59:41,864][WARN][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=\>"[http://10.70.25.150:9200/](http://10.70.25.150:9200/)"}  
[2019-04-21T14:59:41,942][INFO][logstash.outputs.elasticsearch] ES Output version determined {:es\_version=\>6}  
[2019-04-21T14:59:41,946][WARN][logstash.outputs.elasticsearch] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>6}  
[2019-04-21T14:59:41,980][INFO][logstash.outputs.elasticsearch] New Elasticsearch output {:class=\>"LogStash::Outputs::ElasticSearch", :hosts=\>["[//10.70.25.150:9200](https://10.70.25.150:9200)"]}  
[2019-04-21T14:59:42,069][INFO][logstash.outputs.elasticsearch] Using default mapping template  
[2019-04-21T14:59:42,128][INFO][logstash.outputs.elasticsearch] Index Lifecycle Management is set to 'auto', but will be disabled - Your Elasticsearch cluster is before 7.0.0, which is the minimum version required to automatically run Index Lifecycle Management  
[2019-04-21T14:59:42,130][INFO][logstash.outputs.elasticsearch] Attempting to install template {:manage\_template=\>{"template"=\>"logstash-_", "version"=\>60001, "settings"=\>{"index.refresh\_interval"=\>"5s"}, "mappings"=\>{"default"=\>{"dynamic\_templates"=\>[{"message\_field"=\>{"path\_match"=\>"message", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false}}}, {"string\_fields"=\>{"match"=\>"_", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false, "fields"=\>{"keyword"=\>{"type"=\>"keyword", "ignore\_above"=\>256}}}}}], "properties"=\>{"@timestamp"=\>{"type"=\>"date"}, "@version"=\>{"type"=\>"keyword"}, "geoip"=\>{"dynamic"=\>true, "properties"=\>{"ip"=\>{"type"=\>"ip"}, "location"=\>{"type"=\>"geo\_point"}, "latitude"=\>{"type"=\>"half\_float"}, "longitude"=\>{"type"=\>"half\_float"}}}}}}}}  
[2019-04-21T14:59:42,404][ERROR][logstash.javapipeline] Pipeline aborted due to error {:pipeline\_id=\>"main", :exception=\>#\<Grok::PatternError: pattern %{sis\_al\_time:al\_time} not defined\>, :backtrace=\>["/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/jls-grok-0.11.5/lib/grok-pure.rb:123:in `block in compile'", "org/jruby/RubyKernel.java:1411:in`loop'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/jls-grok-0.11.5/lib/grok-pure.rb:93:in `compile'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-filter-grok-4.0.4/lib/logstash/filters/grok.rb:281:in`block in register'", "org/jruby/RubyArray.java:1792:in `each'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-filter-grok-4.0.4/lib/logstash/filters/grok.rb:275:in`block in register'", "org/jruby/RubyHash.java:1419:in `each'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-filter-grok-4.0.4/lib/logstash/filters/grok.rb:270:in`register'", "org/logstash/config/ir/compiler/AbstractFilterDelegatorExt.java:56:in `register'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:191:in`block in register\_plugins'", "org/jruby/RubyArray.java:1792:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:190:in`register\_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:446:in `maybe_setup_out_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:203:in`start\_workers'", "/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:145:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:104:in`block in start'"], :thread=\>"#\<Thread:0x73abc2c0 run\>"}  
[2019-04-21T14:59:42,434][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
[2019-04-21T14:59:42,901][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-04-21T14:59:47,824][INFO][logstash.runner] Logstash shut down.

What is wrong ?

Thanks

Miko

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [April 21, 2019, 12:49pm UTC](https://discuss.elastic.co/t/logstash-error-start-error/177749/2 "2019-04-21T12:49:25Z")

</div>

> [@MikoMan](#):
>
> Pipeline aborted due to error {:pipeline\_id=\>"main", :exception=\>#\<Grok::PatternError: pattern %{sis\_al\_time:al\_time} not defined\>

You have configured a grok filter to match the pattern sis\_al\_time and save the match into the field al\_time. However, that is not one of the standard patterns and you have not defined it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 19, 2019, 12:49pm UTC](https://discuss.elastic.co/t/logstash-error-start-error/177749/3 "2019-05-19T12:49:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
