# Logstash Error "The signal HUP is in use by the JVM and will not work correctly on this platform"-SOLVED

**URL:** <https://discuss.elastic.co/t/logstash-error-the-signal-hup-is-in-use-by-the-jvm-and-will-not-work-correctly-on-this-platform-solved/57622>\
**Category:** Logstash\
**Created:** [August 9, 2016, 7:19pm UTC](https://discuss.elastic.co/t/logstash-error-the-signal-hup-is-in-use-by-the-jvm-and-will-not-work-correctly-on-this-platform-solved/57622 "2016-08-09T19:19:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![kmk3173](https://avatars.discourse-cdn.com/v4/letter/k/8baadc/32.png) [@kmk3173](https://discuss.elastic.co/u/kmk3173)\
**Post date:** [August 9, 2016, 7:19pm UTC](https://discuss.elastic.co/t/logstash-error-the-signal-hup-is-in-use-by-the-jvm-and-will-not-work-correctly-on-this-platform-solved/57622/1 "2016-08-09T19:19:22Z")

</div>

Does anyone know a fix for this?

I am running ELK on a Windows 7 machine  
Elasticsearch 2.3.3  
Logstash 2.3.2  
Kibana 4.5.1

I am trying to run my config file to import csv file

I used the following command C:\Elk\logstash\>bin\logstash -f "C:\Elk\logstash\conf\csv\_output.conf"

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [August 9, 2016, 7:36pm UTC](https://discuss.elastic.co/t/logstash-error-the-signal-hup-is-in-use-by-the-jvm-and-will-not-work-correctly-on-this-platform-solved/57622/2 "2016-08-09T19:36:10Z")

</div>

This message is benign. See [https://github.com/elastic/logstash/issues/5239](https://github.com/elastic/logstash/issues/5239).

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [October 5, 2016, 1:18pm UTC](https://discuss.elastic.co/t/logstash-error-the-signal-hup-is-in-use-by-the-jvm-and-will-not-work-correctly-on-this-platform-solved/57622/3 "2016-10-05T13:18:02Z")

</div>

> [@](#):
>
> The signal HUP is in use by the JVM and will not work correctly on this platform.

This message is not fatal to Logstash. If you are having configuration errors, they are not what is generating these messages. The HUP message is actually from [JRuby](https://github.com/jruby/jruby/blob/915993886ae6663586d893b7d237f750068aceb5/core/src/main/ruby/jruby/kernel/signal.rb#L35).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:35am UTC](https://discuss.elastic.co/t/logstash-error-the-signal-hup-is-in-use-by-the-jvm-and-will-not-work-correctly-on-this-platform-solved/57622/4 "2017-07-06T04:35:37Z")

</div>


