# Logstash : error when running

**URL:** <https://discuss.elastic.co/t/logstash-error-when-running/93728>\
**Category:** Logstash\
**Created:** [July 19, 2017, 9:11am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728 "2017-07-19T09:11:41Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![marwa](https://avatars.discourse-cdn.com/v4/letter/m/67e7ee/32.png) [@marwa](https://discuss.elastic.co/u/marwa)\
**Post date:** [July 19, 2017, 9:11am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728/1 "2017-07-19T09:11:41Z")

</div>

Hello i jaust installed logsatsh-5.5.0 on my server then when i first tryed to run it by the command line bin/logstash -e 'input { stdin { } } output { stdout {} }'  
many errors appeared 2017-07-19 09:54:23,269 main ERROR Unable to create file /opt/logstash-5.5.0/logs/logstash-slowlog-plain.log java.io.IOException: No such file or directory

Caused by: java.lang.IllegalStateException: ManagerFactory [org.apache.logging.log4j.core.appender.rolling.RollingFileManager$RollingFileManagerFactory@30591043] unable to create manager for [/opt/logstash-5.5.0/logs/logstash-slowlog-plain.log] with data [org.apache.logging.log4j.core.appender.rolling.RollingFileManager$FactoryData@1ecfdaf4[pattern=/opt/logstash-5.5.0/logs/logstash-slowlog-plain-%d{yyyy-MM-dd}.log, append=true, bufferedIO=true, bufferSize=8192, policy=CompositeTriggeringPolicy(policies=[TimeBasedTriggeringPolicy(nextRolloverMillis=0, interval=1, modulate=true)]), strategy=DefaultRolloverStrategy(min=1, max=7), advertiseURI=null, layout=[%d{ISO8601}][%-5p][%-25c] %.10000m%n]]  
at org.apache.logging.log4j.core.appender.AbstractManager.getManager(AbstractManager.java:75)  
at org.apache.logging.log4j.core.appender.OutputStreamManager.getManager(OutputStreamManager.java:81)  
at org.apache.logging.log4j.core.appender.rolling.RollingFileManager.getFileManager(RollingFileManager.java:103)  
at org.apache.logging.log4j.core.appender.RollingFileAppender.createAppender(RollingFileAppender.java:191)  
... 105 more

2017-07-19 09:54:23,806 main ERROR Unable to create file /opt/logstash-5.5.0/logs/logstash-slowlog-plain.log java.io.IOException: No such file or directory

```
    at org.apache.logging.log4j.core.appender.rolling.RollingFileManager$RollingFileManagerFactory.createManager(RollingFileManager.java:403)
    at org.apache.logging.log4j.core.appender.AbstractManager.getManager(AbstractManager.java:73)
    at org.apache.logging.log4j.core.appender.OutputStreamManager.getManager(OutputStreamManager.java:81)
    at org.apache.logging.log4j.core.appender.rolling.RollingFileManager.getFileManager(RollingFileManager.java:103)
    at org.apache.logging.log4j.core.appender.RollingFileAppender.createAppender(RollingFileAppender.java:191)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.apache.logging.log4j.core.config.plugins.util.PluginBuilder.build(PluginBuilder.java:132)
    at org.apache.logging.log4j.core.config.AbstractConfiguration.createPluginObject(AbstractConfiguration.java:918)
    at org.apache.logging.log4j.core.config.AbstractConfiguration.createConfiguration(AbstractConfiguration.java:858)
    at org.apache.logging.log4j.core.config.AbstractConfiguration.createConfiguration(AbstractConfiguration.java:850)
    at org.apache.logging.log4j.core.config.AbstractConfiguration.doConfigure(AbstractConfiguration.java:479)
    at org.apache.logging.log4j.core.config.AbstractConfiguration.initialize(AbstractConfiguration.java:219)
    at org.apache.logging.log4j.core.config.AbstractConfiguration.start(AbstractConfiguration.java:231)
    at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:496)
    at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:249)
    at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:239)
   
    at opt.logstash_minus_5_dot_5_dot_0.lib.bootstrap.environment. __file__ (/opt/logstash-5.5.0/lib/bootstrap/environment.rb:71)
    at opt.logstash_minus_5_dot_5_dot_0.lib.bootstrap.environment.load(/opt/logstash-5.5.0/lib/bootstrap/environment.rb)
    at org.jruby.Ruby.runScript(Ruby.java:857)

```

Caused by: java.lang.IllegalStateException: ManagerFactory [org.apache.logging.log4j.core.appender.rolling.RollingFileManager$RollingFileManagerFactory@30591043] unable to create manager for [/opt/logstash-5.5.0/logs/logstash-slowlog-plain.log] with data [org.apache.logging.log4j.core.appender.rolling.RollingFileManager$FactoryData@9c9e9f3[pattern=/opt/logstash-5.5.0/logs/logstash-slowlog-plain-%d{yyyy-MM-dd}.log, append=true, bufferedIO=true, bufferSize=8192, policy=CompositeTriggeringPolicy(policies=[TimeBasedTriggeringPolicy(nextRolloverMillis=0, interval=1, modulate=true)]), strategy=DefaultRolloverStrategy(min=1, max=7), advertiseURI=null, layout=org.apache.logging.log4j.core.layout.JsonLayout@67ab1cbb]]  
at org.apache.logging.log4j.core.appender.AbstractManager.getManager(AbstractManager.java:75)  
at org.apache.logging.log4j.core.appender.OutputStreamManager.getManager(OutputStreamManager.java:81)  
at org.apache.logging.log4j.core.appender.rolling.RollingFileManager.getFileManager(RollingFileManager.java:103)  
at org.apache.logging.log4j.core.appender.RollingFileAppender.createAppender(RollingFileAppender.java:191)  
... 105 more

2017-07-19 09:54:24,121 main ERROR Null object returned for RollingFile in Appenders.  
2017-07-19 09:54:24,122 main ERROR Null object returned for RollingFile in Appenders.  
2017-07-19 09:54:24,123 main ERROR Null object returned for RollingFile in Appenders.  
2017-07-19 09:54:24,123 main ERROR Null object returned for RollingFile in Appenders.  
2017-07-19 09:54:24,124 main ERROR Unable to locate appender "plain\_rolling" for logger config "root"  
2017-07-19 09:54:24,125 main ERROR Unable to locate appender "plain\_rolling\_slowlog" for logger config "slowlog"  
[2017-07-19T09:54:24,329][INFO][logstash.pipeline] Starting pipeline {"id"=\>"main", "pipeline.workers"=\>8, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>5, "pipeline.max\_inflight"=\>1000}  
[2017-07-19T09:54:24,355][INFO][logstash.pipeline] Pipeline main started  
The stdin plugin is now waiting for input:  
[2017-07-19T09:54:24,403][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
hello\_world  
in fact the pipeline was created successfully but i don't get the reasons why all these errors appeared !!!! i have to fix them please any help !!!!!

---

<div class="post-metadata">

**Author:** ![Vishal\_Sharma1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vishal_sharma1/32/20207_2.png) [@Vishal\_Sharma1](https://discuss.elastic.co/u/Vishal_Sharma1)\
**Post date:** [July 19, 2017, 9:16am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728/2 "2017-07-19T09:16:42Z")

</div>

did you run it like  
$ sudo bin/logstash -e 'input { stdin { } } output { stdout {} }' ?

---

<div class="post-metadata">

**Author:** ![marwa](https://avatars.discourse-cdn.com/v4/letter/m/67e7ee/32.png) [@marwa](https://discuss.elastic.co/u/marwa)\
**Post date:** [July 19, 2017, 9:19am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728/3 "2017-07-19T09:19:30Z")

</div>

Thank you very much ,i tryed and every thing went well  
so the problm maintains in the permission ??

---

<div class="post-metadata">

**Author:** ![Vishal\_Sharma1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vishal_sharma1/32/20207_2.png) [@Vishal\_Sharma1](https://discuss.elastic.co/u/Vishal_Sharma1)\
**Post date:** [July 19, 2017, 9:27am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728/4 "2017-07-19T09:27:19Z")

</div>

Yes, as a user you need to run it using sudo

---

<div class="post-metadata">

**Author:** ![marwa](https://avatars.discourse-cdn.com/v4/letter/m/67e7ee/32.png) [@marwa](https://discuss.elastic.co/u/marwa)\
**Post date:** [July 19, 2017, 9:29am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728/5 "2017-07-19T09:29:58Z")

</div>

just one an other question, is it necessary to create a config file for the pipeline in /etc/logstash/conf.d because i installed logstash in /opt/ and did not find logstash directory in /etc/ so does it pose a problem ??

---

<div class="post-metadata">

**Author:** ![Vishal\_Sharma1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vishal_sharma1/32/20207_2.png) [@Vishal\_Sharma1](https://discuss.elastic.co/u/Vishal_Sharma1)\
**Post date:** [July 19, 2017, 11:43am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728/6 "2017-07-19T11:43:09Z")

</div>

Yes you need to

---

<div class="post-metadata">

**Author:** ![marwa](https://avatars.discourse-cdn.com/v4/letter/m/67e7ee/32.png) [@marwa](https://discuss.elastic.co/u/marwa)\
**Post date:** [July 20, 2017, 10:10am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728/7 "2017-07-20T10:10:26Z")

</div>

last day everything worked with sudo , i did not change anything , i am trying now but look an an error appears  
sudo bin/logstash -e 'input { stdin { } } output { stdout {} }'  
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.  
Sending Logstash's logs to /opt/logstash-5.5.0/logs which is now configured via log4j2.properties  
[2017-07-20T11:08:13,997][INFO][logstash.pipeline] Starting pipeline {"id"=\>"main", "pipeline.workers"=\>8, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>5, "pipeline.max\_inflight"=\>1000}  
[2017-07-20T11:08:14,032][INFO][logstash.pipeline] Pipeline main started  
The stdin plugin is now waiting for input:  
[2017-07-20T11:08:14,090][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
hello  
2017-07-20T10:08:20.657Z [vds005.insightscale.tn](http://vds005.insightscale.tn) hello  
^C[2017-07-20T11:08:24,952][WARN][logstash.runner] SIGINT received. Shutting down the agent.  
[2017-07-20T11:08:24,962][WARN][logstash.agent] stopping pipeline {:id=\>"main"}

any help please !!!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 17, 2017, 10:10am UTC](https://discuss.elastic.co/t/logstash-error-when-running/93728/8 "2017-08-17T10:10:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
