# Logstash Error: "Your settings are invalid"

**URL:** https://discuss.elastic.co/t/logstash-error-your-settings-are-invalid/291544
**Category:** Logstash
**Created:** [December 12, 2021, 2:01pm UTC](https://discuss.elastic.co/t/logstash-error-your-settings-are-invalid/291544 "2021-12-12T14:01:14Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![neerajg](https://avatars.discourse-cdn.com/v4/letter/n/f17d59/32.png) [@neerajg](https://discuss.elastic.co/u/neerajg)
#### Post date: [December 12, 2021, 2:01pm UTC](https://discuss.elastic.co/t/logstash-error-your-settings-are-invalid/291544/1 "2021-12-12T14:01:14Z")

</div>

Hi guys,

I just upgraded elk stack from 7.15.0 to 7.16.0.

Everything is working fine except Logstash.

It ends up failing to start. I checked the system logs and found the following error.

Error:

```auto
logstash[20212]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
logstash[20212]: Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
logstash[20212]: [2021-12-12T02:43:59,474][INFO][logstash.runner] Log4j configuration path used is: /etc/logstash/log4j2.properties
logstash[20212]: [2021-12-12T02:43:59,486][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.16.0", "jruby.version"=>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.13+8 on 11.0.13+8 +indy +jit [linux-x86_64]"}
logstash[20212]: Your settings are invalid. Reason: super: no superclass method `validate' for #<LogStash::Setting::DeprecatedAlias:0x7488db31>
logstash[20212]: [2021-12-12T02:43:59,519][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
logstash[20212]: org.jruby.exceptions.SystemExit: (SystemExit) exit
logstash[20212]: #011at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.20.1.jar:?]
logstash[20212]: #011at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.20.1.jar:?]
logstash[20212]: #011at usr.share.logstash.lib.bootstrap.environment.<main>(/usr/share/logstash/lib/bootstrap/environment.rb:94) ~[?:?]
systemd[1]: logstash.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: logstash.service: Failed with result 'exit-code'.
systemd[1]: logstash.service: Service hold-off time over, scheduling restart.
systemd[1]: logstash.service: Scheduled restart job, restart counter is at 14.
systemd[1]: Stopped logstash.

```

The _0x7488db31_ keeps changing at every restart try.

I tired to downgrade Logstash to 7.15.0 and it works fine. The error only shows up at 7.16.0

Please help me figure out as to what is happening.

Regards,  
Neerajkumar G.

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [December 12, 2021, 4:21pm UTC](https://discuss.elastic.co/t/logstash-error-your-settings-are-invalid/291544/2 "2021-12-12T16:21:52Z")

</div>

> [@neerajg](#):
>
> Please help me figure out as to what is happening.

Perhaps you have http.enabled in your logstash.yml and you need to change that to api.enabled. See [this](https://github.com/elastic/logstash/pull/13481) PR.

---

<div class="post-metadata">

### Author: ![neerajg](https://avatars.discourse-cdn.com/v4/letter/n/f17d59/32.png) [@neerajg](https://discuss.elastic.co/u/neerajg)
#### Post date: [December 13, 2021, 7:52am UTC](https://discuss.elastic.co/t/logstash-error-your-settings-are-invalid/291544/3 "2021-12-13T07:52:03Z")

</div>

Hi Badger,

This worked like a charm!!

Thanks a ton for your help!!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 10, 2022, 7:52am UTC](https://discuss.elastic.co/t/logstash-error-your-settings-are-invalid/291544/4 "2022-01-10T07:52:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
