# Logstash Error

**URL:** <https://discuss.elastic.co/t/logstash-error/244343>\
**Category:** Logstash\
**Created:** [August 10, 2020, 6:19am UTC](https://discuss.elastic.co/t/logstash-error/244343 "2020-08-10T06:19:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Amantha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amantha/32/73592_2.png) [@Amantha](https://discuss.elastic.co/u/Amantha)\
**Post date:** [August 10, 2020, 6:19am UTC](https://discuss.elastic.co/t/logstash-error/244343/1 "2020-08-10T06:19:06Z")

</div>

I run **bin/logstash -e 'input { stdin { } } output { stdout {} }'** command in linux terminal. But it give the following error.

OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.11.1.jar) to method sun.nio.ch.NativeThread.signal(long)  
WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
WARNING: Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console  
[WARN] 2020-08-10 11:39:54.851 [LogStash::Runner] multilocal - Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[FATAL] 2020-08-10 11:39:54.884 [LogStash::Runner] runner - Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must change the "path.data" setting.  
[ERROR] 2020-08-10 11:39:54.886 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

What is the solution for this problem?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 10, 2020, 6:26am UTC](https://discuss.elastic.co/t/logstash-error/244343/2 "2020-08-10T06:26:54Z")

</div>

Welcome to our community! 😃

> [@Amantha](#):
>
> [FATAL] 2020-08-10 11:39:54.884 [LogStash::Runner] runner - Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must change the "path.data" setting.

Is there another instance of Logstash running?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 7, 2020, 6:26am UTC](https://discuss.elastic.co/t/logstash-error/244343/3 "2020-09-07T06:26:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
