# Logstash Error

**URL:** https://discuss.elastic.co/t/logstash-error/287404
**Category:** Logstash
**Created:** [October 22, 2021, 6:16am UTC](https://discuss.elastic.co/t/logstash-error/287404 "2021-10-22T06:16:21Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Mudit\_Tripathi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudit_tripathi/32/79805_2.png) [@Mudit\_Tripathi](https://discuss.elastic.co/u/Mudit_Tripathi)
#### Post date: [October 22, 2021, 6:16am UTC](https://discuss.elastic.co/t/logstash-error/287404/1 "2021-10-22T06:16:21Z")

</div>

Hi Guys,

I have created a sample csv file with 3 columns and I am using to log the csv file into Elasticsearch using logstash.

This is my logstash.conf

input {  
file {  
path =\> "/Users/mudit.tripathi/Downloads/samplelogs.csv"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
}  
filter {  
csv {  
seperator =\> ","  
columns =\> [“Name”,”Tag”,”Status”]  
}  
}  
output {  
Elasticsearch {  
hosts =\> "[https://localhost:9200](https://localhost:9200)"  
index =\> "samplesnapit\_2021"  
}  
stdout {}  
}

I am using this command to run logstash -f logstash.conf

here is the error I am getting:

Using JAVA\_HOME defined java: /Library/Java/JavaVirtualMachines/jdk-17.jdk/Contents/Home  
WARNING, using JAVA\_HOME while Logstash distribution comes with a bundled JDK  
2021-10-22T11:39:55.765+05:30 [main] WARN FilenoUtil : Native subprocess control requires open access to the JDK IO subsystem  
Pass '--add-opens java.base/sun.nio.ch=ALL-UNNAMED --add-opens java.base/java.io=ALL-UNNAMED' to enable.  
Sending Logstash logs to /usr/local/Cellar/logstash-full/7.15.1/libexec/logs which is now configured via log4j2.properties  
[2021-10-22T11:40:05,591][INFO][logstash.runner] Log4j configuration path used is: /usr/local/Cellar/logstash-full/7.15.1/libexec/config/log4j2.properties  
[2021-10-22T11:40:05,597][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.15.1", "jruby.version"=\>"jruby 9.2.19.0 (2.5.8) 2021-06-15 55810c552b Java HotSpot(TM) 64-Bit Server VM 17+35-LTS-2724 on 17+35-LTS-2724 +indy +jit [darwin-x86\_64]"}  
[2021-10-22T11:40:05,657][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2021-10-22T11:40:06,385][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2021-10-22T11:40:06,489][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of [\t\r\n], "#", [A-Za-z0-9\_-], '"', "'", [A-Za-z\_], "-", [0-9], "[", "{", "]" at line 12, column 21 (byte 232) after filter {\n csv {\n seperator =\> ","\n columns =\> [", :backtrace=\>["/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/compiler.rb:32:in `compile_imperative'", "org/logstash/execution/AbstractPipelineExt.java:187:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:72:in `initialize'", "/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/java_pipeline.rb:47:in `initialize'", "/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/pipeline\_action/create.rb:52:in `execute'", "/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/agent.rb:391:in `block in converge\_state'"]}  
[2021-10-22T11:40:06,539][INFO][logstash.runner] Logstash shut down.  
[2021-10-22T11:40:06,546][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit  
org.jruby.exceptions.SystemExit: (SystemExit) exit  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.19.0.jar:?]  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.19.0.jar:?]  
at usr.local.Cellar.logstash\_minus\_full.$7\_dot\_15\_dot\_1.libexec.lib.bootstrap.environment.(/usr/local/Cellar/logstash-full/7.15.1/libexec/lib/bootstrap/environment.rb:94) ~[?:?]

---

<div class="post-metadata">

### Author: ![grumo35](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grumo35/32/59451_2.png) [@grumo35](https://discuss.elastic.co/u/grumo35)
#### Post date: [October 22, 2021, 7:40am UTC](https://discuss.elastic.co/t/logstash-error/287404/2 "2021-10-22T07:40:05Z")

</div>

Hi,

When selecting your configuration i stumble upon the fact that you are using strange double quotes for the columns i believe you copy pasted the code from some sort of text document.

```auto
input {

file {

path => "/Users/mudit.tripathi/Downloads/samplelogs.csv"

start_position => "beginning"

sincedb_path => "/dev/null"

}

}

filter {

csv {

seperator => ","

columns => ["Name","Tag","Status"]

}

}

output {

Elasticsearch {

hosts => "https://localhost:9200"

index => "samplesnapit_2021"

}

stdout {}

}

```

> [@Mudit\_Tripathi](#):
>
> “Name”,”Tag”,”Status”

The " and the ” are different, that's what might cause the issue here.

---

<div class="post-metadata">

### Author: ![Mudit\_Tripathi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudit_tripathi/32/79805_2.png) [@Mudit\_Tripathi](https://discuss.elastic.co/u/Mudit_Tripathi)
#### Post date: [October 22, 2021, 8:23am UTC](https://discuss.elastic.co/t/logstash-error/287404/3 "2021-10-22T08:23:23Z")

</div>

Hi thanks for looking into it. I copied it from pycharm, not sure how this strange comma came. I have changed it. thanks.

input {  
file {  
path =\> "/Users/mudit.tripathi/Downloads/samplelogs.csv"  
start\_position =\> "beginning"  
sincedb\_path =\> "/dev/null"  
}  
}  
filter {  
csv {  
seperator =\> ","  
columns =\> ["Name","Tag","Status"]  
}  
}  
output {  
Elasticsearch {  
hosts =\> "[https://localhost:9200](https://localhost:9200)"  
index =\> "samplesnapit\_2021"  
}  
stdout {}  
}

Now I am getting different error

ERROR  
[2021-10-22T13:51:50,693][INFO][logstash.runner] Log4j configuration path used is: /usr/local/Cellar/logstash-full/7.15.1/libexec/config/log4j2.properties  
[2021-10-22T13:51:50,700][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.15.1", "jruby.version"=\>"jruby 9.2.19.0 (2.5.8) 2021-06-15 55810c552b Java HotSpot(TM) 64-Bit Server VM 17+35-LTS-2724 on 17+35-LTS-2724 +indy +jit [darwin-x86\_64]"}  
[2021-10-22T13:51:50,772][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2021-10-22T13:51:50,780][FATAL][logstash.runner] Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must change the "path.data" setting.  
[2021-10-22T13:51:50,782][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit  
org.jruby.exceptions.SystemExit: (SystemExit) exit  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.19.0.jar:?]  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.19.0.jar:?]  
at usr.local.Cellar.logstash\_minus\_full.$7\_dot\_15\_dot\_1.libexec.lib.bootstrap.environment.(/usr/local/Cellar/logstash-full/7.15.1/libexec/lib/bootstrap/environment.rb:94) ~[?:?]  
PP-C02Z66G1LVCG:logstash-full mudit.tripathi$ logstash -f logstash.conf  
Using JAVA\_HOME defined java: /Library/Java/JavaVirtualMachines/jdk-17.jdk/Contents/Home  
WARNING, using JAVA\_HOME while Logstash distribution comes with a bundled JDK  
2021-10-22T13:52:18.032+05:30 [main] WARN FilenoUtil : Native subprocess control requires open access to the JDK IO subsystem  
Pass '--add-opens java.base/sun.nio.ch=ALL-UNNAMED --add-opens java.base/java.io=ALL-UNNAMED' to enable.  
Sending Logstash logs to /usr/local/Cellar/logstash-full/7.15.1/libexec/logs which is now configured via log4j2.properties  
[2021-10-22T13:52:27,652][INFO][logstash.runner] Log4j configuration path used is: /usr/local/Cellar/logstash-full/7.15.1/libexec/config/log4j2.properties  
[2021-10-22T13:52:27,657][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.15.1", "jruby.version"=\>"jruby 9.2.19.0 (2.5.8) 2021-06-15 55810c552b Java HotSpot(TM) 64-Bit Server VM 17+35-LTS-2724 on 17+35-LTS-2724 +indy +jit [darwin-x86\_64]"}  
[2021-10-22T13:52:27,703][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2021-10-22T13:52:28,455][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2021-10-22T13:52:28,758][INFO][org.reflections.Reflections] Reflections took 62 ms to scan 1 urls, producing 120 keys and 417 values  
[2021-10-22T13:52:29,164][ERROR][logstash.filters.csv] Unknown setting 'seperator' for csv  
[2021-10-22T13:52:29,168][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"Java::JavaLang::IllegalStateException", :message=\>"Unable to configure plugins: (ConfigurationError) Something is wrong with your configuration.", :backtrace=\>["org.logstash.config.ir.CompiledPipeline.(CompiledPipeline.java:119)", "org.logstash.execution.JavaBasePipelineExt.initialize(JavaBasePipelineExt.java:86)", "org.logstash.execution.JavaBasePipelineExt$INVOKER$i$1$0$initialize.call(JavaBasePipelineExt$INVOKER$i$1$0$initialize.gen)", "org.jruby.internal.runtime.methods.JavaMethod$JavaMethodN.call(JavaMethod.java:837)", "org.jruby.ir.runtime.IRRuntimeHelpers.instanceSuper(IRRuntimeHelpers.java:1169)", "org.jruby.ir.runtime.IRRuntimeHelpers.instanceSuperSplatArgs(IRRuntimeHelpers.java:1156)", "org.jruby.ir.targets.InstanceSuperInvokeSite.invoke(InstanceSuperInvokeSite.java:39)", "usr.local.Cellar.logstash\_minus\_full.$7\_dot\_15\_dot\_1.libexec.logstash\_minus\_core.lib.logstash.java\_pipeline.RUBY$method$initialize$0(/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/java\_pipeline.rb:47)", "org.jruby.internal.runtime.methods.CompiledIRMethod.call(CompiledIRMethod.java:80)", "org.jruby.internal.runtime.methods.MixedModeIRMethod.call(MixedModeIRMethod.java:70)", "org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:333)", "org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:87)", "org.jruby.RubyClass.newInstance(RubyClass.java:939)", "org.jruby.RubyClass$INVOKER$i$newInstance.call(RubyClass$INVOKER$i$newInstance.gen)", "org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:207)", "usr.local.Cellar.logstash\_minus\_full.$7\_dot\_15\_dot\_1.libexec.logstash\_minus\_core.lib.logstash.pipeline\_action.create.RUBY$method$execute$0(/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/pipeline\_action/create.rb:52)", "usr.local.Cellar.logstash\_minus\_full.$7\_dot\_15\_dot\_1.libexec.logstash\_minus\_core.lib.logstash.pipeline\_action.create.RUBY$method$execute$0$ **VARARGS** (/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/pipeline\_action/create.rb)", "org.jruby.internal.runtime.methods.CompiledIRMethod.call(CompiledIRMethod.java:80)", "org.jruby.internal.runtime.methods.MixedModeIRMethod.call(MixedModeIRMethod.java:70)", "org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:207)", "usr.local.Cellar.logstash\_minus\_full.$7\_dot\_15\_dot\_1.libexec.logstash\_minus\_core.lib.logstash.agent.RUBY$block$converge\_state$2(/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/agent.rb:391)", "org.jruby.runtime.CompiledIRBlockBody.callDirect(CompiledIRBlockBody.java:138)", "org.jruby.runtime.IRBlockBody.call(IRBlockBody.java:58)", "org.jruby.runtime.IRBlockBody.call(IRBlockBody.java:52)", "org.jruby.runtime.Block.call(Block.java:139)", "org.jruby.RubyProc.call(RubyProc.java:318)", "org.jruby.internal.runtime.RubyRunnable.run(RubyRunnable.java:105)", "java.base/java.lang.Thread.run(Thread.java:833)"]}  
warning: thread "Converge PipelineAction::Create" terminated with exception (report\_on\_exception is true):  
LogStash::Error: Don't know how to handle `Java::JavaLang::IllegalStateException` for `PipelineAction::Create<main>`  
create at org/logstash/execution/ConvergeResultExt.java:135  
add at org/logstash/execution/ConvergeResultExt.java:60  
converge\_state at /usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/agent.rb:404  
[2021-10-22T13:52:29,171][ERROR][logstash.agent] An exception happened when converging configuration {:exception=\>LogStash::Error, :message=\>"Don't know how to handle `Java::JavaLang::IllegalStateException` for `PipelineAction::Create<main>`"}  
[2021-10-22T13:52:29,175][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<LogStash::Error: Don't know how to handle `Java::JavaLang::IllegalStateException` for `PipelineAction::Create<main>`\>, :backtrace=\>["org/logstash/execution/ConvergeResultExt.java:135:in `create'", "org/logstash/execution/ConvergeResultExt.java:60:in `add'", "/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/agent.rb:404:in `block in converge\_state'"]}  
[2021-10-22T13:52:29,180][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit  
org.jruby.exceptions.SystemExit: (SystemExit) exit  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.19.0.jar:?]  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.19.0.jar:?]  
at usr.local.Cellar.logstash\_minus\_full.$7\_dot\_15\_dot\_1.libexec.lib.bootstrap.environment.(/usr/local/Cellar/logstash-full/7.15.1/libexec/lib/bootstrap/environment.rb:94) ~[?:?]

---

<div class="post-metadata">

### Author: ![grumo35](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grumo35/32/59451_2.png) [@grumo35](https://discuss.elastic.co/u/grumo35)
#### Post date: [October 22, 2021, 2:02pm UTC](https://discuss.elastic.co/t/logstash-error/287404/4 "2021-10-22T14:02:12Z")

</div>

> [@Mudit\_Tripathi](#):
>
> seperator =\> ","

Please change seperator to separator

---

<div class="post-metadata">

### Author: ![Mudit\_Tripathi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudit_tripathi/32/79805_2.png) [@Mudit\_Tripathi](https://discuss.elastic.co/u/Mudit_Tripathi)
#### Post date: [October 25, 2021, 5:03am UTC](https://discuss.elastic.co/t/logstash-error/287404/5 "2021-10-25T05:03:40Z")

</div>

ok. it ran this time i got SSL error. I fixed it. by using http instead of https.  
now the pipeline ran but there were errors.

[2021-10-25T10:37:25,454][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2021-10-25T10:37:25,746][INFO][org.reflections.Reflections] Reflections took 51 ms to scan 1 urls, producing 120 keys and 417 values  
[2021-10-25T10:37:26,271][INFO][logstash.outputs.Elasticsearch][main] New Elasticsearch output {:class=\>"LogStash::Outputs::Elasticsearch", :hosts=\>["[http://localhost:9200](http://localhost:9200)"]}  
[2021-10-25T10:37:26,424][INFO][logstash.outputs.Elasticsearch][main] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://localhost:9200/](http://localhost:9200/)]}}  
[2021-10-25T10:37:26,496][WARN][logstash.outputs.Elasticsearch][main] Restored connection to ES instance {:url=\>"[http://localhost:9200/](http://localhost:9200/)"}  
[2021-10-25T10:37:26,532][INFO][logstash.outputs.Elasticsearch][main] Elasticsearch version determined (7.10.2-SNAPSHOT) {:es\_version=\>7}  
[2021-10-25T10:37:26,533][WARN][logstash.outputs.Elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>7}  
[2021-10-25T10:37:26,549][ERROR][logstash.outputs.Elasticsearch][main] Unable to get license information {:url=\>"[http://localhost:9200/](http://localhost:9200/)", :exception=\>LogStash::Outputs::Elasticsearch::HttpClient::Pool::BadResponseCodeError, :message=\>"Got response code '400' contacting Elasticsearch at URL '[http://localhost:9200/\_license](http://localhost:9200/_license)'"}  
[2021-10-25T10:37:26,552][ERROR][logstash.outputs.Elasticsearch][main] Could not connect to a compatible version of Elasticsearch {:url=\>"[http://localhost:9200/](http://localhost:9200/)"}  
[2021-10-25T10:37:26,634][INFO][logstash.javapipeline][main] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>16, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50, "pipeline.max\_inflight"=\>2000, "pipeline.sources"=\>["/usr/local/Cellar/logstash-full/logstash.conf"], :thread=\>"#\<Thread:0x7cd72b6 run\>"}  
[2021-10-25T10:37:27,252][INFO][logstash.javapipeline][main] Pipeline Java execution initialization time {"seconds"=\>0.62}  
[2021-10-25T10:37:27,286][INFO][logstash.javapipeline][main] Pipeline started {"pipeline.id"=\>"main"}  
[2021-10-25T10:37:27,305][INFO][filewatch.observingtail][main][008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d] START, creating Discoverer, Watch with file and sincedb collections  
[2021-10-25T10:37:27,319][INFO][logstash.agent] Pipelines running {:count=\>1, :running\_pipelines=\>[:main], :non\_running\_pipelines=\>}  
[2021-10-25T10:37:27,324][ERROR][logstash.javapipeline][main][008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::File start\_position=\>"beginning", path=\>["/Users/mudit.tripathi/Downloads/samplelogs.csv"], id=\>"008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d", sincedb\_path=\>"/dev/null", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_86dad06b-da15-48c8-b282-1db920dcd487", enable\_metric=\>true, charset=\>"UTF-8"\>, stat\_interval=\>1.0, discover\_interval=\>15, sincedb\_write\_interval=\>15.0, delimiter=\>"\n", close\_older=\>3600.0, mode=\>"tail", file\_completed\_action=\>"delete", sincedb\_clean\_after=\>1209600.0, file\_chunk\_size=\>32768, file\_chunk\_count=\>140737488355327, file\_sort\_by=\>"last\_modified", file\_sort\_direction=\>"asc", exit\_after\_read=\>false, check\_archive\_validity=\>false\>  
Error: Permission denied - Permission denied  
Exception: Errno::EACCES  
Stack: org/jruby/RubyFile.java:1267:in `utime' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1133:in `block in touch'  
org/jruby/RubyArray.java:1820:in `each' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1130:in `touch'  
/usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/filewatch/sincedb\_collection.rb:22:in `initialize' /usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/filewatch/observing_base.rb:62:in `build\_watch\_and\_dependencies'  
/usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/filewatch/observing\_base.rb:56:in `initialize' /usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/logstash/inputs/file.rb:352:in `start\_processing'  
/usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/logstash/inputs/file.rb:368:in `run' /usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/java_pipeline.rb:405:in `inputworker'  
/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/java\_pipeline.rb:396:in `block in start_input' [2021-10-25T10:37:28,338][INFO][filewatch.observingtail][main][008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d] START, creating Discoverer, Watch with file and sincedb collections [2021-10-25T10:37:28,340][ERROR][logstash.javapipeline][main][008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d] A plugin had an unrecoverable error. Will restart this plugin. Pipeline_id:main Plugin: <LogStash::Inputs::File start_position=>"beginning", path=>["/Users/mudit.tripathi/Downloads/samplelogs.csv"], id=>"008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d", sincedb_path=>"/dev/null", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_86dad06b-da15-48c8-b282-1db920dcd487", enable_metric=>true, charset=>"UTF-8">, stat_interval=>1.0, discover_interval=>15, sincedb_write_interval=>15.0, delimiter=>"\n", close_older=>3600.0, mode=>"tail", file_completed_action=>"delete", sincedb_clean_after=>1209600.0, file_chunk_size=>32768, file_chunk_count=>140737488355327, file_sort_by=>"last_modified", file_sort_direction=>"asc", exit_after_read=>false, check_archive_validity=>false> Error: Permission denied - Permission denied Exception: Errno::EACCES Stack: org/jruby/RubyFile.java:1267:in `utime'  
uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1133:in `block in touch' org/jruby/RubyArray.java:1820:in `each'  
uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1130:in `touch' /usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/filewatch/sincedb_collection.rb:22:in `initialize'  
/usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/filewatch/observing\_base.rb:62:in `build_watch_and_dependencies' /usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/filewatch/observing_base.rb:56:in `initialize'  
/usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/logstash/inputs/file.rb:352:in `start_processing' /usr/local/Cellar/logstash-full/7.15.1/libexec/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.4.0/lib/logstash/inputs/file.rb:368:in `run'  
/usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/java\_pipeline.rb:405:in `inputworker' /usr/local/Cellar/logstash-full/7.15.1/libexec/logstash-core/lib/logstash/java_pipeline.rb:396:in `block in start\_input'  
[2021-10-25T10:37:29,344][INFO][filewatch.observingtail][main][008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d] START, creating Discoverer, Watch with file and sincedb collections  
[2021-10-25T10:37:29,360][ERROR][logstash.javapipeline][main][008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::File start\_position=\>"beginning", path=\>["/Users/mudit.tripathi/Downloads/samplelogs.csv"], id=\>"008b12e652d9ef75bf481081144f95a9a9a2b8d261d279d5f05dd9be8c2ff69d", sincedb\_path=\>"/dev/null", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_86dad06b-da15-48c8-b282-1db920dcd487", enable\_metric=\>true, charset=\>"UTF-8"\>, stat\_interval=\>1.0, discover\_interval=\>15, sincedb\_write\_interval=\>15.0, delimiter=\>"\n", close\_older=\>3600.0, mode=\>"tail", file\_completed\_action=\>"delete", sincedb\_clean\_after=\>1209600.0, file\_chunk\_size=\>32768, file\_chunk\_count=\>140737488355327, file\_sort\_by=\>"last\_modified", file\_sort\_direction=\>"asc", exit\_after\_read=\>false, check\_archive\_validity=\>false\>  
Error: Permission denied - Permission denied  
Exception: Errno::EACCES  
Stack: org/jruby/RubyFile.java:1267:in `utime' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1133:in `block in touch'  
org/jruby/RubyArray.java:1820:in `each' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1130:in `touch'

this keeps on coming in logs.

---

<div class="post-metadata">

### Author: ![Mudit\_Tripathi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudit_tripathi/32/79805_2.png) [@Mudit\_Tripathi](https://discuss.elastic.co/u/Mudit_Tripathi)
#### Post date: [October 25, 2021, 9:22am UTC](https://discuss.elastic.co/t/logstash-error/287404/6 "2021-10-25T09:22:27Z")

</div>

issue is fixed. many thanks to you sir!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 22, 2021, 9:22am UTC](https://discuss.elastic.co/t/logstash-error/287404/7 "2021-11-22T09:22:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
