# LOGSTASH ES INPUT

**URL:** https://discuss.elastic.co/t/logstash-es-input/184542
**Category:** Logstash
**Tags:** elastic-stack-security
**Created:** [June 6, 2019, 9:37am UTC](https://discuss.elastic.co/t/logstash-es-input/184542 "2019-06-06T09:37:18Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Alessio\_Creo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alessio_creo/32/43381_2.png) [@Alessio\_Creo](https://discuss.elastic.co/u/Alessio_Creo)
#### Post date: [June 6, 2019, 9:37am UTC](https://discuss.elastic.co/t/logstash-es-input/184542/1 "2019-06-06T09:37:18Z")

</div>

Hi there,

I'm trying to use elasticsearch input in Logstash. My ES node is secured via TLS. I've configured  
**ca\_file** setting in Logstash with my CAchain but I obtain

> http client did not trust this server's certificate

in Elasticsearch and

```
error:
  2210 2210
  2210 Faraday::SSLError
  2210 certificate verify failed

```

In Logstash.  
Logstash worksfine in output. Any suggestion to find the problem?

Thanks a lot.

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [June 6, 2019, 11:29pm UTC](https://discuss.elastic.co/t/logstash-es-input/184542/2 "2019-06-06T23:29:22Z")

</div>

Please provide the exact configuration you have in Logstash and Elasticsearch.

---

<div class="post-metadata">

### Author: ![Alessio\_Creo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alessio_creo/32/43381_2.png) [@Alessio\_Creo](https://discuss.elastic.co/u/Alessio_Creo)
#### Post date: [June 7, 2019, 5:48am UTC](https://discuss.elastic.co/t/logstash-es-input/184542/3 "2019-06-07T05:48:21Z")

</div>

Thank you very much for the reply. I solved the problem. It wasn't an ES or LS problem, it was that the Host from I were running LS didn't relsoved the hostname of the Host where was running ES so I had to connect specifying the IP but the IP it wasn't in the certificate for TLS encryption. So a few configuration for hosts resolving fixed the problem.

Thank you.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2019, 5:48am UTC](https://discuss.elastic.co/t/logstash-es-input/184542/4 "2019-07-05T05:48:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
