# Logstash fail to start,it shows translation missing: en.logstash.runner.configuration.file-not-found

**URL:** <https://discuss.elastic.co/t/logstash-fail-to-start-it-shows-translation-missing-en-logstash-runner-configuration-file-not-found/51189>\
**Category:** Logstash\
**Created:** [May 27, 2016, 6:41pm UTC](https://discuss.elastic.co/t/logstash-fail-to-start-it-shows-translation-missing-en-logstash-runner-configuration-file-not-found/51189 "2016-05-27T18:41:15Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Hobbit](https://avatars.discourse-cdn.com/v4/letter/h/67e7ee/32.png) [@Hobbit](https://discuss.elastic.co/u/Hobbit)\
**Post date:** [May 27, 2016, 6:41pm UTC](https://discuss.elastic.co/t/logstash-fail-to-start-it-shows-translation-missing-en-logstash-runner-configuration-file-not-found/51189/1 "2016-05-27T18:41:15Z")

</div>

Hi !  
I'm following the doc to set up the first-pipeline-conf,but after I ran `bin/logstash -f first-pipeline.conf --configtest` ,this error shows:  
`An unexpected error occurred! {:error=>#<RuntimeError: translation missing: en.logstash.runner.configuration.file-not-found>, :class=>"RuntimeError", :backtrace=>["/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.2-java/lib/logstash/config/loader.rb:58:in`local\_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.2-java/lib/logstash/config/loader.rb:37:in `load_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.2-java/lib/logstash/config/loader.rb:17:in`format\_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.2-java/lib/logstash/agent.rb:181:in `execute'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.2-java/lib/logstash/runner.rb:94:in`run'", "org/jruby/RubyProc.java:281:in `call'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.2-java/lib/logstash/runner.rb:99:in`run'", "org/jruby/RubyProc.java:281:in `call'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/stud-0.0.22/lib/stud/task.rb:24:in`initialize'"], :level=\>:warn} `

pipeline started when I just ran `bin/logstash -e 'input { stdin { } } output { stdout {} }'`

anyone has any ideas?Thanks a lot!

---

<div class="post-metadata">

**Author:** ![shikha.agarwal1](https://avatars.discourse-cdn.com/v4/letter/s/67e7ee/32.png) [@shikha.agarwal1](https://discuss.elastic.co/u/shikha.agarwal1)\
**Post date:** [May 27, 2016, 6:54pm UTC](https://discuss.elastic.co/t/logstash-fail-to-start-it-shows-translation-missing-en-logstash-runner-configuration-file-not-found/51189/2 "2016-05-27T18:54:08Z")

</div>

Have you created first-pipeline.conf? If so, what is the location? and what is the content of this file?

---

<div class="post-metadata">

**Author:** ![Hobbit](https://avatars.discourse-cdn.com/v4/letter/h/67e7ee/32.png) [@Hobbit](https://discuss.elastic.co/u/Hobbit)\
**Post date:** [May 27, 2016, 6:57pm UTC](https://discuss.elastic.co/t/logstash-fail-to-start-it-shows-translation-missing-en-logstash-runner-configuration-file-not-found/51189/3 "2016-05-27T18:57:06Z")

</div>

I'm so sorry....I had a typo in the command...that's why I got that error massage...my mind is not clear...I didn't see a delete button here so ....😰😰..so sorry ignore it plz..

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:55am UTC](https://discuss.elastic.co/t/logstash-fail-to-start-it-shows-translation-missing-en-logstash-runner-configuration-file-not-found/51189/4 "2017-07-06T04:55:52Z")

</div>


