# Logstash Failed to install template Error 400

**URL:** https://discuss.elastic.co/t/logstash-failed-to-install-template-error-400/315403
**Category:** Logstash
**Created:** [September 28, 2022, 8:34pm UTC](https://discuss.elastic.co/t/logstash-failed-to-install-template-error-400/315403 "2022-09-28T20:34:39Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![fformoso](https://avatars.discourse-cdn.com/v4/letter/f/b3f665/32.png) [@fformoso](https://discuss.elastic.co/u/fformoso)
#### Post date: [September 28, 2022, 8:34pm UTC](https://discuss.elastic.co/t/logstash-failed-to-install-template-error-400/315403/1 "2022-09-28T20:34:39Z")

</div>

Dear all,

I need help to understand root cause, I can add the template via api, but not using logstash 8.3

I've tried to fix it adding diferent roles to user =\> "logstash\_writer" and didnt work

Error:

[2022-09-28T17:30:13,750][ERROR][logstash.outputs.elasticsearch][main] Failed to install template {:message=\>"Got response code '400' contacting Elasticsearch at URL '[https://uyaslogstash01.uy.corp:9200/\_index\_template/banking\_analytics\_monitor\_sqlv01](https://uyaslogstash01.uy.corp:9200/_index_template/banking_analytics_monitor_sqlv01)'", :exception=\>LogStash::Outputs::Elasticsearch::HttpClient::Pool::BadResponseCodeError, :backtrace=\>["/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/http\_client/manticore\_adapter.rb:84:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:324:in `perform\_request\_to\_url'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:311:in `block in perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:398:in `with\_connection'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:310:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:318:in `block in Pool'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/http\_client.rb:408:in `template_put'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/http_client.rb:85:in `template\_install'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/template\_manager.rb:29:in `install'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch/template_manager.rb:17:in `install\_template'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch.rb:494:in `install_template'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch.rb:318:in `finish\_register'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/outputs/elasticsearch.rb:283:in `block in register'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-11.6.0-java/lib/logstash/plugin_mixins/elasticsearch/common.rb:154:in `block in after\_successful\_connection'"]}

Logstash conf file output:

...  
user =\> "logstash\_writer"  
template\_name =\> "banking\_analytics\_monitor\_sqlv01"  
template =\> "/etc/logstash/templates/monitor\_templateSQL04\_LS10\_vSQL.json"  
...

Template file: monitor\_templateSQL04\_LS10\_vSQL.json

{  
"index\_patterns": ["ba\_monitor\_\*"],  
"order": 1,  
"settings": {  
"number\_of\_shards": 2,  
"number\_of\_replicas": 0,  
"index.mapping.ignore\_malformed": true  
},  
"mappings": {  
"properties": {  
"@timestamp": {  
"type": "date"  
},  
"@version": {  
"type": "text",  
"fields": {  
"keyword": {  
"type": "keyword",  
"ignore\_above": 256  
}  
}  
},  
"correlation": {  
"type": "keyword"  
},  
"datetime": {  
"type": "date"  
},  
"layer": {  
"type": "keyword"  
},  
"processTime": {  
"type": "date"  
},  
"project": {  
"type": "keyword"  
},  
"result": {  
"type": "keyword"  
},  
"channel": {  
"type": "keyword"  
},  
"service": {  
"type": "keyword"  
},  
"time": {  
"type": "long"  
}

```
            }
    }

```

}

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 26, 2022, 8:34pm UTC](https://discuss.elastic.co/t/logstash-failed-to-install-template-error-400/315403/2 "2022-10-26T20:34:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
