# Logstash Failed to load the sqljdbc\_auth.dll cause : no sqljdbc\_auth in java.library.path

**URL:** <https://discuss.elastic.co/t/logstash-failed-to-load-the-sqljdbc-auth-dll-cause-no-sqljdbc-auth-in-java-library-path/259530>\
**Category:** Logstash\
**Created:** [December 23, 2020, 9:27pm UTC](https://discuss.elastic.co/t/logstash-failed-to-load-the-sqljdbc-auth-dll-cause-no-sqljdbc-auth-in-java-library-path/259530 "2020-12-23T21:27:57Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![jjfellers](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jjfellers/32/81340_2.png) [@jjfellers](https://discuss.elastic.co/u/jjfellers)\
**Post date:** [December 23, 2020, 9:27pm UTC](https://discuss.elastic.co/t/logstash-failed-to-load-the-sqljdbc-auth-dll-cause-no-sqljdbc-auth-in-java-library-path/259530/1 "2020-12-23T21:27:58Z")

</div>

I have pasted the required dll in about 20 different places. Always the same error. With the default logstash installation on CentOS, where is the correct place to place the sqljdbc42.jar (version 4.2.8112) and dll? I placed the jar and dll in /usr/share/logstash/logstash-core/lib/jars. My java version:  
OpenJDK Runtime Environment (rhel-2.6.22.2.el7\_8-x86\_64 u261-b02)  
OpenJDK 64-Bit Server VM (build 24.261-b02, mixed mode)

I am not setting JAVA\_HOME so it is using the bundled JDK. which is:  
OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.8+10)  
OpenJDK 64-Bit Server VM AdoptOpenJDK (build 11.0.8+10, mixed mode)

I tried placing the sqljdbc\_auth.dll in several places... I tried both the x86 and x64 version (should be x64). Out of ideas.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 20, 2021, 9:28pm UTC](https://discuss.elastic.co/t/logstash-failed-to-load-the-sqljdbc-auth-dll-cause-no-sqljdbc-auth-in-java-library-path/259530/2 "2021-01-20T21:28:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
