# Logstash failed to run

**URL:** <https://discuss.elastic.co/t/logstash-failed-to-run/247294>\
**Category:** Logstash\
**Created:** [September 2, 2020, 10:05pm UTC](https://discuss.elastic.co/t/logstash-failed-to-run/247294 "2020-09-02T22:05:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![billzhang1123](https://avatars.discourse-cdn.com/v4/letter/b/4bbf92/32.png) [@billzhang1123](https://discuss.elastic.co/u/billzhang1123)\
**Post date:** [September 2, 2020, 10:05pm UTC](https://discuss.elastic.co/t/logstash-failed-to-run/247294/1 "2020-09-02T22:05:16Z")

</div>

I have this configuration below running against the latest release of logstash. but received the error below. any suggestion?

input {  
file {  
path =\> "~/logstash-data/ActionTrackingGeneral.csv"  
start\_position =\> "beginning"  
sincedb\_path =\> "NUL"  
}  
}  
filter {  
csv {  
separator =\> ","  
columns =\> ["Number","Facility","Type","Status","ASStatus","OriginationDate","OriginationDueDate","Priority","Description","Link"]  
}  
}  
output {  
elasticsearch {  
hosts =\> ["localhost:9200"]  
index =\> "test-test"  
}  
stdout {codec =\> json\_lines }  
}

[2020-09-02T21:54:35,244][INFO][logstash.outputs.elasticsearch][main] Attempting to install template {:manage\_template=\>{"index\_patterns"=\>"logstash-_", "version"=\>60001, "settings"=\>{"index.refresh\_interval"=\>"5s", "number\_of\_shards"=\>1}, "mappings"=\>{"dynamic\_templates"=\>[{"message\_field"=\>{"path\_match"=\>"message", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false}}}, {"string\_fields"=\>{"match"=\>"_", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false, "fields"=\>{"keyword"=\>{"type"=\>"keyword", "ignore\_above"=\>256}}}}}], "properties"=\>{"@timestamp"=\>{"type"=\>"date"}, "@version"=\>{"type"=\>"keyword"}, "geoip"=\>{"dynamic"=\>true, "properties"=\>{"ip"=\>{"type"=\>"ip"}, "location"=\>{"type"=\>"geo\_point"}, "latitude"=\>{"type"=\>"half\_float"}, "longitude"=\>{"type"=\>"half\_float"}}}}}}}  
[2020-09-02T21:54:36,757][INFO][logstash.javapipeline][main] Pipeline Java execution initialization time {"seconds"=\>1.55}  
[2020-09-02T21:54:37,990][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
[2020-09-02T21:54:38,497][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2020-09-02T21:54:43,411][INFO][logstash.runner] Logstash shut down.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 2, 2020, 10:14pm UTC](https://discuss.elastic.co/t/logstash-failed-to-run/247294/2 "2020-09-02T22:14:07Z")

</div>

Welcome to our community! 😃

If you are on linux, your `sincedb_path` should be `/dev/null`.  
How are you starting Logstash here, via a service, or calling it directly?

---

<div class="post-metadata">

**Author:** ![billzhang1123](https://avatars.discourse-cdn.com/v4/letter/b/4bbf92/32.png) [@billzhang1123](https://discuss.elastic.co/u/billzhang1123)\
**Post date:** [September 3, 2020, 12:47am UTC](https://discuss.elastic.co/t/logstash-failed-to-run/247294/3 "2020-09-03T00:47:45Z")

</div>

I changed it but no luck. I kicked it off with this command:  
./logstash -f ../config/load/ActionTrackingGeneral.config

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 1, 2020, 12:47am UTC](https://discuss.elastic.co/t/logstash-failed-to-run/247294/4 "2020-10-01T00:47:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
