# Logstash failed to start after plugin update

**URL:** <https://discuss.elastic.co/t/logstash-failed-to-start-after-plugin-update/268472>\
**Category:** Logstash\
**Created:** [March 26, 2021, 11:00am UTC](https://discuss.elastic.co/t/logstash-failed-to-start-after-plugin-update/268472 "2021-03-26T11:00:20Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![anandd4](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anandd4/32/50610_2.png) [@anandd4](https://discuss.elastic.co/u/anandd4)\
**Post date:** [March 26, 2021, 11:00am UTC](https://discuss.elastic.co/t/logstash-failed-to-start-after-plugin-update/268472/1 "2021-03-26T11:00:20Z")

</div>

After updating beats input plugin from 6.0.5 to 6.1.0 on logstash(7.5.2), the service stopped to work & keeps on throwing the following error -

```
`logstash[22854]: [ERROR] 2021-03-26 10:35:57.423 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) load error: /usr/share/logstash/logstash-core/lib/logstash/runner -- java.lang.RuntimeException: BUG: refined marker called as method`

```

Can someone please shed more light on this error and how to get this fixed. Thanks

PS - logstash works fine without the plugin update

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [March 26, 2021, 5:09pm UTC](https://discuss.elastic.co/t/logstash-failed-to-start-after-plugin-update/268472/2 "2021-03-26T17:09:05Z")

</div>

> [@anandd4](#):
>
> `java.lang.RuntimeException: BUG: refined marker called as method`

As it says, that is a bug. Does logstash log a stack trace? If so, please post it. If not, someone will have to run it in a debugger, reproduce the problem and set a breakpoint on the init of a RuntimeException and get the stack trace that way. If you have the skill set to do so, please post the stack trace. If not, I would suggest downgrading to 6.0.5.

---

<div class="post-metadata">

**Author:** ![anandd4](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anandd4/32/50610_2.png) [@anandd4](https://discuss.elastic.co/u/anandd4)\
**Post date:** [March 30, 2021, 8:00am UTC](https://discuss.elastic.co/t/logstash-failed-to-start-after-plugin-update/268472/3 "2021-03-30T08:00:42Z")

</div>

Its happening due to the following issue -  
`https://github.com/jruby/jruby/issues/6038`  
Fixed in logstash 7.10+ so anyone facing this issue has option to either upgrade the logstash version or revert back to original version of beats 6.0.5(recommended)

Ps - I've noticed that Logstash7.5 works fine with 6.0.11 version of beats. We are testing this but its too early to say that it works completely with any issues. I'll update this thread in couple of days with my findings with the revised beats plugin

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 27, 2021, 8:01am UTC](https://discuss.elastic.co/t/logstash-failed-to-start-after-plugin-update/268472/4 "2021-04-27T08:01:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
