# Logstash failed to start up because of memory issues

**URL:** <https://discuss.elastic.co/t/logstash-failed-to-start-up-because-of-memory-issues/95007>\
**Category:** Logstash\
**Created:** [July 28, 2017, 8:00pm UTC](https://discuss.elastic.co/t/logstash-failed-to-start-up-because-of-memory-issues/95007 "2017-07-28T20:00:25Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![shroh](https://avatars.discourse-cdn.com/v4/letter/s/74df32/32.png) [@shroh](https://discuss.elastic.co/u/shroh)\
**Post date:** [July 28, 2017, 8:00pm UTC](https://discuss.elastic.co/t/logstash-failed-to-start-up-because-of-memory-issues/95007/1 "2017-07-28T20:00:26Z")

</div>

My Log stash failed to start up because of memory issues:

This is what i see  
[root@ip-10-206-118-171 logstash]# /usr/share/logstash/bin/logstash --path.settings /etc/logstash  
OpenJDK 64-Bit Server VM warning: INFO: os::commit\_memory(0x000000054a660000, 10562961408, 0) failed; error='Cannot allocate memory' (errno=12)

# 

# There is insufficient memory for the Java Runtime Environment to continue.

# Native memory allocation (mmap) failed to map 10562961408 bytes for committing reserved memory.

# An error report file with more information is saved as:

# /var/log/logstash/hs\_err\_pid3900.log

[root@ip-10-206-118-171 logstash]#

Memory information on the box .

/proc/meminfo:  
MemTotal: 7747256 kB  
MemFree: 1851672 kB  
MemAvailable: 3888596 kB

Logstash JVM options.

## JVM configuration

# Xms represents the initial size of total heap space

# Xmx represents the maximum size of total heap space

-Xms10g  
-Xmx10g

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [August 11, 2017, 6:15pm UTC](https://discuss.elastic.co/t/logstash-failed-to-start-up-because-of-memory-issues/95007/2 "2017-08-11T18:15:13Z")

</div>

Why are you setting `-Xmx10g` when you only have 8 GB RAM?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 8, 2017, 6:15pm UTC](https://discuss.elastic.co/t/logstash-failed-to-start-up-because-of-memory-issues/95007/3 "2017-09-08T18:15:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
