# Logstash failed to stop the service

**URL:** <https://discuss.elastic.co/t/logstash-failed-to-stop-the-service/63958>\
**Category:** Logstash\
**Created:** [October 26, 2016, 5:25am UTC](https://discuss.elastic.co/t/logstash-failed-to-stop-the-service/63958 "2016-10-26T05:25:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![bopa](https://avatars.discourse-cdn.com/v4/letter/b/a6a055/32.png) [@bopa](https://discuss.elastic.co/u/bopa)\
**Post date:** [October 26, 2016, 5:25am UTC](https://discuss.elastic.co/t/logstash-failed-to-stop-the-service/63958/1 "2016-10-26T05:25:55Z")

</div>

I'm experiencing the logstash service failed to start after I issue

**systemctl restart logstash**

Output:

_ **systemctl status logstash** _  
_ **● logstash.service - LSB: Starts Logstash as a daemon.** _  
_\*\* Loaded: loaded (/etc/rc.d/init.d/logstash)\*\*_  
_\*\* Active: active (running) since Wed 2016-10-26 10:51:15 IST; 4min 25s ago\*\*_  
_\*\* Docs: man:systemd-sysv-generator(8)\*\*_  
_\*\* Process: 16200 ExecStop=/etc/rc.d/init.d/logstash stop (code=exited, status=1/FAILURE)\*\*_  
_\*\* Process: 16237 ExecStart=/etc/rc.d/init.d/logstash start (code=exited, status=0/SUCCESS)\*\*_  
_\*\* CGroup: /system.slice/logstash.service\*\*_  
_\*\* └─1380 /bin/java -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -Djava.awt.headless=true -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingO...\*\*_

even though the service says active logstash port is not open and my client PC can't communicate with the logstash server.

what could be the issue??

---

<div class="post-metadata">

**Author:** ![bopa](https://avatars.discourse-cdn.com/v4/letter/b/a6a055/32.png) [@bopa](https://discuss.elastic.co/u/bopa)\
**Post date:** [October 26, 2016, 5:50am UTC](https://discuss.elastic.co/t/logstash-failed-to-stop-the-service/63958/2 "2016-10-26T05:50:24Z")

</div>

I found the issue.

It is because I have wrongly configured the network.host attribute in elasticsearch.yml file.  
after matched it with the logstash.conf hosts: attribute evething seems to work fine..😁

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:32am UTC](https://discuss.elastic.co/t/logstash-failed-to-stop-the-service/63958/3 "2017-07-06T04:32:49Z")

</div>


