# Logstash failing to starting due to the error related to the "i18n" gem

**URL:** <https://discuss.elastic.co/t/logstash-failing-to-starting-due-to-the-error-related-to-the-i18n-gem/345341>\
**Category:** Logstash\
**Created:** [October 19, 2023, 1:45am UTC](https://discuss.elastic.co/t/logstash-failing-to-starting-due-to-the-error-related-to-the-i18n-gem/345341 "2023-10-19T01:45:23Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![akhilatham](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akhilatham/32/126679_2.png) [@akhilatham](https://discuss.elastic.co/u/akhilatham)\
**Post date:** [October 19, 2023, 1:45am UTC](https://discuss.elastic.co/t/logstash-failing-to-starting-due-to-the-error-related-to-the-i18n-gem/345341/1 "2023-10-19T01:45:23Z")

</div>

I am getting the below error:

[2023-10-18T17:37:02,573][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<ArgumentError: wrong number of arguments (given 2, expected 0..1)\>, :backtrace=\>["/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/i18n-1.14.1/lib/i18n.rb:210:in `translate'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:427:in `inputworker'", "/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:405:in `block in start\_input'"]}

PFB, logstash configuration of the same:

#logstash configuration for creating a simple

# Beats -\> Logstash -\> Elasticsearch pipeline.

input {  
beats {  
port =\> 5044  
host =\> "10.5.68.149, 10.5.68.150"  
#host =\> "0.0.0.0" # Listen on all available network interfaces  
}  
}

output {  
elasticsearch {  
hosts =\> ["elasticsesarch:9200"]  
user =\> "elastic"  
password =\> "password"

}  
}

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 19, 2023, 2:09am UTC](https://discuss.elastic.co/t/logstash-failing-to-starting-due-to-the-error-related-to-the-i18n-gem/345341/2 "2023-10-19T02:09:27Z")

</div>

Over at github there is an open [issue](https://github.com/elastic/logstash/issues/15451) for this, although that is perhaps a duplicate of another recent [issue](https://github.com/elastic/logstash/issues/15407).

Might be fixed by downgrading to 8.9.x or even 8.8.x.

May be related to the JRuby update in 8.10. The i18n code has [extensive comments](https://github.com/ruby-i18n/i18n/blob/7cf09474b77fd41e65d979134b0525f67cf371b0/lib/i18n.rb#L197) about how calls to the .t alias will fail in different versions of ruby. The call is [here](https://github.com/elastic/logstash/blob/6046402a3582eb813cfdc9c3ed5dca89e961ed6e/logstash-core/lib/logstash/java_pipeline.rb#L427).

---

<div class="post-metadata">

**Author:** ![akhilatham](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akhilatham/32/126679_2.png) [@akhilatham](https://discuss.elastic.co/u/akhilatham)\
**Post date:** [October 21, 2023, 12:31am UTC](https://discuss.elastic.co/t/logstash-failing-to-starting-due-to-the-error-related-to-the-i18n-gem/345341/3 "2023-10-21T00:31:26Z")

</div>

Dowgrading logstash to 8.9.x worked for me. Thanks

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [October 21, 2023, 12:41am UTC](https://discuss.elastic.co/t/logstash-failing-to-starting-due-to-the-error-related-to-the-i18n-gem/345341/4 "2023-10-21T00:41:35Z")

</div>

Can you try to remove/comment the line:  
`# host => "10.5.68.149, 10.5.68.150"`

According to [the doc](https://www.elastic.co/guide/en/logstash/current/plugins-inputs-beats.html#plugins-inputs-beats-host), should be a string, not an array.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 18, 2023, 12:42am UTC](https://discuss.elastic.co/t/logstash-failing-to-starting-due-to-the-error-related-to-the-i18n-gem/345341/5 "2023-11-18T00:42:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
