# Logstash Fails to insert the data in Elasticseach

**URL:** https://discuss.elastic.co/t/logstash-fails-to-insert-the-data-in-elasticseach/89709
**Category:** Logstash
**Created:** [June 16, 2017, 12:14pm UTC](https://discuss.elastic.co/t/logstash-fails-to-insert-the-data-in-elasticseach/89709 "2017-06-16T12:14:18Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![moni15moni](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moni15moni/32/42311_2.png) [@moni15moni](https://discuss.elastic.co/u/moni15moni)
#### Post date: [June 16, 2017, 12:14pm UTC](https://discuss.elastic.co/t/logstash-fails-to-insert-the-data-in-elasticseach/89709/1 "2017-06-16T12:14:18Z")

</div>

Hi

While Logstash getting started with the following config

elasticsearch {  
manage\_template =\> false  
codec =\> "json"  
hosts =\>["10.4.1.70:9299"]  
index =\> "%{[@metadata][INDEX\_NAME]}"  
document\_type =\> "logs"  
}  
I am getting the following error,

[2017-06-14T09:59:45,144][ERROR][logstash.outputs.elasticsearch] Got a bad response code from server, but this code is not considered retryable. Request will be dropped {:code=\>400, :response\_body=\>"No handler found for uri [/\_template/logstash/\_bulk/\_bulk/\_bulk] and method [POST]"} [2017-06-14T09:59:4

/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk/\_bulk

Continuously it's getting increased .I am using the Logstash - 5.1 and Elasticsearch- 5.1 Version.

Any one can explain the root cause.

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [June 16, 2017, 12:19pm UTC](https://discuss.elastic.co/t/logstash-fails-to-insert-the-data-in-elasticseach/89709/2 "2017-06-16T12:19:31Z")

</div>

I'm not sure what's going on here but deleting `codec => "json"` won't make anything worse.

---

<div class="post-metadata">

### Author: ![moni15moni](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moni15moni/32/42311_2.png) [@moni15moni](https://discuss.elastic.co/u/moni15moni)
#### Post date: [June 16, 2017, 12:20pm UTC](https://discuss.elastic.co/t/logstash-fails-to-insert-the-data-in-elasticseach/89709/3 "2017-06-16T12:20:44Z")

</div>

I am just using that for testing ,I have removed that as well

---

<div class="post-metadata">

### Author: ![moni15moni](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moni15moni/32/42311_2.png) [@moni15moni](https://discuss.elastic.co/u/moni15moni)
#### Post date: [June 16, 2017, 12:21pm UTC](https://discuss.elastic.co/t/logstash-fails-to-insert-the-data-in-elasticseach/89709/4 "2017-06-16T12:21:26Z")

</div>

While running in elasticsearch i am getting the following exception

2017-06-16T11:58:26,278][DEBUG][r.suppressed] path: /bad-request, params: {index=bad-request}  
org.elasticsearch.index.IndexNotFoundException: no such index  
at org.elasticsearch.cluster.metadata.IndexNameExpressionResolver$WildcardExpressionResolver.infe(IndexNameExpressionResolver.java:660) ~[elasticsearch-5.1.1.jar:5.1.1]  
at org.elasticsearch.cluster.metadata.IndexNameExpressionResolver$WildcardExpressionResolver.innerResolve(IndexNameExpressionResolver.java:617) ~[elasticsearch-5.1.1.jar:5.1.1]

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 14, 2017, 12:21pm UTC](https://discuss.elastic.co/t/logstash-fails-to-insert-the-data-in-elasticseach/89709/5 "2017-07-14T12:21:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
