# Logstash fails to start with central configuration(bug in 6.0.0-beta1)

**URL:** <https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648>\
**Category:** Logstash\
**Created:** [August 10, 2017, 4:56pm UTC](https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648 "2017-08-10T16:56:39Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![arthur](https://avatars.discourse-cdn.com/v4/letter/a/958977/32.png) [@arthur](https://discuss.elastic.co/u/arthur)\
**Post date:** [August 10, 2017, 4:56pm UTC](https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648/1 "2017-08-10T16:56:40Z")

</div>

I have Elasticsearch6.0.0beta1 and logstash6.0.0beta1 installed on my Mac. Both have x-pack plugin installed.  
My Elasticsearch.yml contains "xpack.security.enabled: false" and everything works. When trying to start Logstash with central configuration, it won't start since I don't use pack security.

Logstash.yml:  
xpack.management.enabled: true  
xpack.management.elasticsearch.url: "[http://localhost:9200/](http://localhost:9200/)"  
xpack.management.logstash.poll\_interval: 5s  
[xpack.management.pipeline.id](http://xpack.management.pipeline.id): ["local\_cloudtrail"]

Message on runtime:  
[2017-08-10T19:45:26,911][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<ArgumentError: You must set the password using the "xpack.management.elasticsearch.password" in logstash.yml\>

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 10, 2017, 9:10pm UTC](https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648/2 "2017-08-10T21:10:47Z")

</div>

The centralised management feature is part of our Gold/Platinum level functionality, so the expectation there is that the cluster would have authentication enabled to protect access to the configs.

It's not mentioned in the docs though and we will get that updated accordingly.

---

<div class="post-metadata">

**Author:** ![arthur](https://avatars.discourse-cdn.com/v4/letter/a/958977/32.png) [@arthur](https://discuss.elastic.co/u/arthur)\
**Post date:** [August 11, 2017, 11:56am UTC](https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648/3 "2017-08-11T11:56:42Z")

</div>

> [@warkolm](#):
>
> The centralised management feature is part of our Gold/Platinum level functionality, so the expectation there is that the cluster would have authentication enabled to protect access to the configs.

Thanks for your reply. Would it be documented, or modified? Not all subscription users have authentication.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 11, 2017, 10:11pm UTC](https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648/4 "2017-08-11T22:11:02Z")

</div>

> [@arthur](#):
>
> Not all subscription users have authentication.

Yes they do, see [Subscriptions | Elastic Stack Products & Support | Elastic](https://www.elastic.co/subscriptions)

---

<div class="post-metadata">

**Author:** ![arthur](https://avatars.discourse-cdn.com/v4/letter/a/958977/32.png) [@arthur](https://discuss.elastic.co/u/arthur)\
**Post date:** [August 12, 2017, 10:11am UTC](https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648/5 "2017-08-12T10:11:36Z")

</div>

I meant that not all subscriptions users are using pack security, like I did now 🙂

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 13, 2017, 7:16am UTC](https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648/6 "2017-08-13T07:16:13Z")

</div>

Oh right, not sure why you'd not be using it!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 10, 2017, 7:16am UTC](https://discuss.elastic.co/t/logstash-fails-to-start-with-central-configuration-bug-in-6-0-0-beta1/96648/7 "2017-09-10T07:16:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
