# Logstash fails to start

**URL:** https://discuss.elastic.co/t/logstash-fails-to-start/181972
**Category:** Logstash
**Created:** [May 21, 2019, 10:05am UTC](https://discuss.elastic.co/t/logstash-fails-to-start/181972 "2019-05-21T10:05:34Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![premkumar](https://avatars.discourse-cdn.com/v4/letter/p/e99b99/32.png) [@premkumar](https://discuss.elastic.co/u/premkumar)
#### Post date: [May 21, 2019, 10:05am UTC](https://discuss.elastic.co/t/logstash-fails-to-start/181972/1 "2019-05-21T10:05:34Z")

</div>

Hi Team,  
I just downloaded logstash (version 7.1.0) for linux and trying to start it. But it get failed with the following error.

[dev@devlinux bin]$ ./logstash -f /home/dev/Desktop/LOGSTASH/logstash-simple.conf  
Sending Logstash logs to /media/sf\_ELK/logstash-7.1.0.tar/logstash-7.1.0/logs which is now configured via log4j2.properties  
[2019-05-21T05:38:23,289][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2019-05-21T05:38:23,387][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.1.0"}  
[2019-05-21T05:38:47,031][INFO][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://localhost:9200/](http://localhost:9200/)]}}  
[2019-05-21T05:38:47,591][WARN][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=\>"[http://localhost:9200/](http://localhost:9200/)"}  
warning: thread "[main]-pipeline-manager" terminated with exception (report\_on\_exception is true):  
java.lang.NoClassDefFoundError: com/fasterxml/jackson/module/afterburner/AfterburnerModule  
at com.jrjackson.JrJacksonRuby.\_\_parse(JrJacksonRuby.java:75)  
at com.jrjackson.JrJacksonRuby.parse(JrJacksonRuby.java:63)  
at com.jrjackson.JrJacksonRuby$INVOKER$s$2$0$parse.call(JrJacksonRuby$INVOKER$s$2$0$parse.gen)  
at org.jruby.internal.runtime.methods.JavaMethod$JavaMethodN.call(JavaMethod.java:835)  
at org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:183)  
at  
Please find the content of the logstash configuration file.  
input { stdin { } }  
output {  
elasticsearch { hosts =\> ["localhost:9200"] }  
stdout { codec =\> rubydebug }  
}

Please provide a solution to start the logstash

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 18, 2019, 10:05am UTC](https://discuss.elastic.co/t/logstash-fails-to-start/181972/2 "2019-06-18T10:05:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
