# Logstash Fails To Startup

**URL:** https://discuss.elastic.co/t/logstash-fails-to-startup/173022
**Category:** Logstash
**Created:** [March 19, 2019, 4:55pm UTC](https://discuss.elastic.co/t/logstash-fails-to-startup/173022 "2019-03-19T16:55:08Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![drod](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drod/32/47881_2.png) [@drod](https://discuss.elastic.co/u/drod)
#### Post date: [March 19, 2019, 4:55pm UTC](https://discuss.elastic.co/t/logstash-fails-to-startup/173022/1 "2019-03-19T16:55:08Z")

</div>

When I try to start up my logstash agent with a basic config, I get the following.

`[ERROR] 2019-03-19 16:50:26.469 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) load error: jopenssl/load -- java.lang.InternalError: null`

The command I use to start it is below.

`logstash -e "input {stdin {}}output {stdout {}}" --debug`

I have tried running this as sudo also. Anybody have any suggestions on how to debug this.

I am running the following version of java.

`openjdk version "1.8.0_121" OpenJDK Runtime Environment (IcedTea 3.3.0) (Gentoo icedtea-3.3.0) OpenJDK 64-Bit Server VM (build 25.121-b13, mixed mode)`

---

<div class="post-metadata">

### Author: ![kharvey](https://avatars.discourse-cdn.com/v4/letter/k/d07c76/32.png) [@kharvey](https://discuss.elastic.co/u/kharvey)
#### Post date: [March 20, 2019, 3:49pm UTC](https://discuss.elastic.co/t/logstash-fails-to-startup/173022/2 "2019-03-20T15:49:58Z")

</div>

I haven't seen that error before. And your start command works on my test logstash setup.

Try Googling "load error: jopenssl/load". There are a handful of hits for logstash like this one:

> <https://github.com/elastic/logstash/issues/7770>

---

<div class="post-metadata">

### Author: ![drod](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drod/32/47881_2.png) [@drod](https://discuss.elastic.co/u/drod)
#### Post date: [March 21, 2019, 1:34am UTC](https://discuss.elastic.co/t/logstash-fails-to-startup/173022/3 "2019-03-21T01:34:11Z")

</div>

As suspected it was a java version issue. Java was updated to

```auto
openjdk version "1.8.0_171"
OpenJDK Runtime Environment (IcedTea 3.8.0) (Gentoo icedtea-3.8.0)
OpenJDK 64-Bit Server VM (build 25.171-b11, mixed mode)

```

and all of a sudden it is working. Thanks for taking a look.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 18, 2019, 1:34am UTC](https://discuss.elastic.co/t/logstash-fails-to-startup/173022/4 "2019-04-18T01:34:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
