# Logstash falls from time to time. tcp input module error

**URL:** <https://discuss.elastic.co/t/logstash-falls-from-time-to-time-tcp-input-module-error/34775>\
**Category:** Logstash\
**Created:** [November 17, 2015, 9:39am UTC](https://discuss.elastic.co/t/logstash-falls-from-time-to-time-tcp-input-module-error/34775 "2015-11-17T09:39:15Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ipeacocks](https://avatars.discourse-cdn.com/v4/letter/i/a8b319/32.png) [@ipeacocks](https://discuss.elastic.co/u/ipeacocks)\
**Post date:** [November 17, 2015, 9:39am UTC](https://discuss.elastic.co/t/logstash-falls-from-time-to-time-tcp-input-module-error/34775/1 "2015-11-17T09:39:15Z")

</div>

Hello.

Sometimes our Logstash falls with such error in logs:

```
{:timestamp=>"2015-11-11T15:55:33.706000+0000", :message=>"An error occurred. Closing 
connection", :client=>"10.100.54.60:31166", :exception=>#<LogStash::ShutdownSignal: 
LogStash::ShutdownSignal>, :backtrace=>["org/jruby/ext/thread/SizedQueue.java:133:in `push'", 
"/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-tcp-1.0.0/lib/logstash/inputs/tcp.rb:122:in 
`handle_socket'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-codec-json_lines-
1.0.1/lib/logstash/codecs/json_lines.rb:38:in `decode'", 
"/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-codec-line-1.0.0/lib/logstash/codecs/line.rb:36:in 
`decode'", "org/jruby/RubyArray.java:1613:in `each'", 
"/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-codec-line-1.0.0/lib/logstash/codecs/line.rb:35:in 
`decode'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-codec-json_lines-
1.0.1/lib/logstash/codecs/json_lines.rb:37:in `decode'", 
"/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-tcp-1.0.0/lib/logstash/inputs/tcp.rb:118:in 
`handle_socket'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-tcp-
1.0.0/lib/logstash/inputs/tcp.rb:147:in `client_thread'", 
"/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-tcp-1.0.0/lib/logstash/inputs/tcp.rb:145:in 
`client_thread'"], :level=>:error}

```

On elastic Github I saw such error [https://github.com/logstash-plugins/logstash-input-tcp/issues/12](https://github.com/logstash-plugins/logstash-input-tcp/issues/12) but I am not sure if this a root cause of problem or it is just Logstash cant close its process correct.

Could somebody help me?

PS. I use Logstash 1.5.5 and Amazon Linux (AWS).

PPS. Seems that this problem also occurred in other people [LS forwarder erroring out on the LS server](https://discuss.elastic.co/t/ls-forwarder-erroring-out-on-the-ls-server/25740)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:22am UTC](https://discuss.elastic.co/t/logstash-falls-from-time-to-time-tcp-input-module-error/34775/2 "2017-07-06T05:22:33Z")

</div>


