# Logstash-filter-aggregate (2.5.0) fails with latest logstash (5.0.2)

**URL:** <https://discuss.elastic.co/t/logstash-filter-aggregate-2-5-0-fails-with-latest-logstash-5-0-2/68269>\
**Category:** Logstash\
**Created:** [December 7, 2016, 9:29am UTC](https://discuss.elastic.co/t/logstash-filter-aggregate-2-5-0-fails-with-latest-logstash-5-0-2/68269 "2016-12-07T09:29:31Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jeslopalo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jeslopalo/32/13675_2.png) [@jeslopalo](https://discuss.elastic.co/u/jeslopalo)\
**Post date:** [December 7, 2016, 9:29am UTC](https://discuss.elastic.co/t/logstash-filter-aggregate-2-5-0-fails-with-latest-logstash-5-0-2/68269/1 "2016-12-07T09:29:32Z")

</div>

Hi,

after update logstash from 5.0.0 to 5.0.2 my pipeline fails when aggregating events with logstash-filter-aggregate.

Is something changed with aggragate syntax? It's a compatibility issue?

```
Sending Logstash's logs to /var/log/logstash which is now configured via log4j2.properties
SystemStackError: stack level too deep
    synchronize at org/jruby/ext/thread/Mutex.java:149
         filter at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-filter-aggregate-2.5.0/lib/logstash/filters/aggregate.rb:427
   multi_filter at /usr/share/logstash/logstash-core/lib/logstash/filters/base.rb:156
           each at org/jruby/RubyArray.java:1613
   multi_filter at /usr/share/logstash/logstash-core/lib/logstash/filters/base.rb:153
   multi_filter at /usr/share/logstash/logstash-core/lib/logstash/filter_delegator.rb:41
     initialize at (eval):441
           each at org/jruby/RubyArray.java:1613
     initialize at (eval):432
           call at org/jruby/RubyProc.java:281
    filter_func at (eval):302
   filter_batch at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:260
           call at org/jruby/RubyProc.java:281
           each at /usr/share/logstash/logstash-core/lib/logstash/util/wrapped_synchronous_queue.rb:186
           each at org/jruby/RubyHash.java:1342
           each at /usr/share/logstash/logstash-core/lib/logstash/util/wrapped_synchronous_queue.rb:185
   filter_batch at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:258
    worker_loop at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:246
  start_workers at /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:225

```

Thank you,

Jesús López

---

<div class="post-metadata">

**Author:** ![jeslopalo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jeslopalo/32/13675_2.png) [@jeslopalo](https://discuss.elastic.co/u/jeslopalo)\
**Post date:** [December 12, 2016, 8:01am UTC](https://discuss.elastic.co/t/logstash-filter-aggregate-2-5-0-fails-with-latest-logstash-5-0-2/68269/2 "2016-12-12T08:01:08Z")

</div>

This issue is being discussed here =\> [https://github.com/logstash-plugins/logstash-filter-aggregate/issues/51](https://github.com/logstash-plugins/logstash-filter-aggregate/issues/51)

---

<div class="post-metadata">

**Author:** ![jeslopalo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jeslopalo/32/13675_2.png) [@jeslopalo](https://discuss.elastic.co/u/jeslopalo)\
**Post date:** [December 19, 2016, 11:48am UTC](https://discuss.elastic.co/t/logstash-filter-aggregate-2-5-0-fails-with-latest-logstash-5-0-2/68269/3 "2016-12-19T11:48:05Z")

</div>

This issue has been resolved here =\> [https://github.com/logstash-plugins/logstash-filter-aggregate/issues/51](https://github.com/logstash-plugins/logstash-filter-aggregate/issues/51)

Thanks to @fbaligand

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 16, 2017, 11:48am UTC](https://discuss.elastic.co/t/logstash-filter-aggregate-2-5-0-fails-with-latest-logstash-5-0-2/68269/4 "2017-01-16T11:48:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
