# Logstash generating exception in pipelineworker

**URL:** <https://discuss.elastic.co/t/logstash-generating-exception-in-pipelineworker/132527>\
**Category:** Logstash\
**Created:** [May 18, 2018, 6:25pm UTC](https://discuss.elastic.co/t/logstash-generating-exception-in-pipelineworker/132527 "2018-05-18T18:25:29Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![imortalsolitude](https://avatars.discourse-cdn.com/v4/letter/i/6f9a4e/32.png) [@imortalsolitude](https://discuss.elastic.co/u/imortalsolitude)\
**Post date:** [May 18, 2018, 6:25pm UTC](https://discuss.elastic.co/t/logstash-generating-exception-in-pipelineworker/132527/1 "2018-05-18T18:25:29Z")

</div>

Hi ,

When i run the logstash after upgrading it to 6.2.4, it is generating error as the below. Can i please know whether the error is due to the wrong filter or deprecated syntax in the filter configuration the same configuration was working in 6.1

Exception in pipelineworker, the pipeline stopped processing new events, please check your filter configuration and restart Logstash. {:pipeline\_id=\>"main", "exception"=\>"Operation not permitted", "backtrace"=\>["org/jruby/ext/socket/RubyUDPSocket.java:339:in `send'", "uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/resolv.rb:846:in`send'", "uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/resolv.rb:680:in `request'", "uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/resolv.rb:536:in`block in fetch\_resource'", "uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/resolv.rb:1108:in `block in resolv'", "org/jruby/RubyArray.java:1734:in`each'", "uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/  
[FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<IOError: Operation not permitted\>, :backtrace=\>["org/jruby/ext/socket/RubyUDPSocket.java:339:in `send'", "uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/resolv.rb:846:in`send'",

---

<div class="post-metadata">

**Author:** ![imortalsolitude](https://avatars.discourse-cdn.com/v4/letter/i/6f9a4e/32.png) [@imortalsolitude](https://discuss.elastic.co/u/imortalsolitude)\
**Post date:** [May 18, 2018, 6:48pm UTC](https://discuss.elastic.co/t/logstash-generating-exception-in-pipelineworker/132527/2 "2018-05-18T18:48:04Z")

</div>

I was able to find the dns filter syntax that was causing the error

dns {  
nameserver =\> ["8.8.8.8"]  
action =\> "append"  
reverse =\> ["dest\_ip"]  
#resolve =\> ["dest\_ip"]  
add\_tag =\> ["dns\_lookup"]  
add\_field =\> { "dns\_name" =\> "%{[dest\_ip[1]]}" }

}

This was working fine in 6.1

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 15, 2018, 7:00pm UTC](https://discuss.elastic.co/t/logstash-generating-exception-in-pipelineworker/132527/3 "2018-06-15T19:00:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
