# Logstash getting auto-restarted very frequently

**URL:** <https://discuss.elastic.co/t/logstash-getting-auto-restarted-very-frequently/103812>\
**Category:** Logstash\
**Created:** [October 13, 2017, 2:49am UTC](https://discuss.elastic.co/t/logstash-getting-auto-restarted-very-frequently/103812 "2017-10-13T02:49:29Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![max\_dodo](https://avatars.discourse-cdn.com/v4/letter/m/c77e96/32.png) [@max\_dodo](https://discuss.elastic.co/u/max_dodo)\
**Post date:** [October 13, 2017, 2:49am UTC](https://discuss.elastic.co/t/logstash-getting-auto-restarted-very-frequently/103812/1 "2017-10-13T02:49:30Z")

</div>

I am using UDP input & output plugin and codec =\> json\_lines . Since few days I am observing that my logstash process is getting restarted every few minutes and below error is noted in the logstash logs. Any one else faced this issue earlier and resolved it. Please help.

[2017-10-12T18:25:57,890][FATAL][logstash.runner] **An unexpected error occurred! {:error=\>#\<SocketError: send: name or service not known\>** , :backtrace=\>["org/jruby/ext/socket/RubyUDPSocket.java:322:in `send'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-udp-3.0.3/lib/logstash/outputs/udp.rb:24:in`register'", "org/jruby/RubyProc.java:281:in `call'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-codec-json_lines-3.0.3/lib/logstash/codecs/json_lines.rb:48:in`encode'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-udp-3.0.3/lib/logstash/outputs/udp.rb:31:in `receive'", "/usr/share/logstash/logstash-core/lib/logstash/outputs/base.rb:92:in`multi\_receive'", "org/jruby/RubyArray.java:1613:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/outputs/base.rb:92:in`multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output\_delegator\_strategies/legacy.rb:22:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:47:in`multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:420:in `output_batch'", "org/jruby/RubyHash.java:1342:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:419:in `output_batch'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:365:in`worker\_loop'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:330:in `start\_workers'"]}

---

<div class="post-metadata">

**Author:** ![max\_dodo](https://avatars.discourse-cdn.com/v4/letter/m/c77e96/32.png) [@max\_dodo](https://discuss.elastic.co/u/max_dodo)\
**Post date:** [October 13, 2017, 6:02pm UTC](https://discuss.elastic.co/t/logstash-getting-auto-restarted-very-frequently/103812/2 "2017-10-13T18:02:16Z")

</div>

Can someone help me on this please. May be this issue has been posted already in the forum in the past which I can't find , but if anyone can provide the cause & solution, it will be a great help.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 10, 2017, 6:02pm UTC](https://discuss.elastic.co/t/logstash-getting-auto-restarted-very-frequently/103812/3 "2017-11-10T18:02:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
