# Logstash giving HUP error

**URL:** <https://discuss.elastic.co/t/logstash-giving-hup-error/60559>\
**Category:** Logstash\
**Created:** [September 15, 2016, 5:15am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559 "2016-09-15T05:15:36Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Senz79](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/senz79/32/42874_2.png) [@Senz79](https://discuss.elastic.co/u/Senz79)\
**Post date:** [September 15, 2016, 5:15am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/1 "2016-09-15T05:15:36Z")

</div>

Hello

I am trying to run LOGSTASH on Windows but i am constantly getting the below error

**"The signal HUP is in use by the JVM and will not work correctly on this platform"**

I have tried all means to resolve the issue

1. Path escape
2. port in use

I am using logstash 2.4.0

Please help

Thanks

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [September 15, 2016, 5:36am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/2 "2016-09-15T05:36:20Z")

</div>

That's harmless, ignore. See [https://github.com/elastic/logstash/issues/5239](https://github.com/elastic/logstash/issues/5239).

---

<div class="post-metadata">

**Author:** ![Senz79](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/senz79/32/42874_2.png) [@Senz79](https://discuss.elastic.co/u/Senz79)\
**Post date:** [September 15, 2016, 5:43am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/3 "2016-09-15T05:43:12Z")

</div>

Thanks for replying ... the link still do not have any resolution. Can you help me in resolving the same

Regards

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [September 15, 2016, 5:46am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/4 "2016-09-15T05:46:24Z")

</div>

I suppose there isn't any resolution available. As I said, ignore it.

---

<div class="post-metadata">

**Author:** ![Senz79](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/senz79/32/42874_2.png) [@Senz79](https://discuss.elastic.co/u/Senz79)\
**Post date:** [September 15, 2016, 5:47am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/5 "2016-09-15T05:47:53Z")

</div>

Ok . But still my logstash service won't start.

D:\Tools\ELK\logstash-2.4.0\bin\>logstash agent -f test.conf  
Settings: Default pipeline workers: 4  
←[31mPipeline aborted due to error {:exception=\>"ArgumentError", :backtrace=\>["D  
:/Tools/ELK/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-file-2.2.  
5/lib/logstash/inputs/file.rb:187:in `register'", "org/jruby/RubyArray.java:1613 :in`each'", "D:/Tools/ELK/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-  
input-file-2.2.5/lib/logstash/inputs/file.rb:185:in `register'", "D:/Tools/ELK/l ogstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash /pipeline.rb:330:in`start\_inputs'", "org/jruby/RubyArray.java:1613:in `each'", "D:/Tools/ELK/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-ja va/lib/logstash/pipeline.rb:329:in`start\_inputs'", "D:/Tools/ELK/logstash-2.4.0  
/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:  
180:in `start_workers'", "D:/Tools/ELK/logstash-2.4.0/vendor/bundle/jruby/1.9/ge ms/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:136:in`run'", "D:/Tools/EL  
K/logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logst  
ash/agent.rb:491:in `start\_pipeline'"], :level=\>:error}←[0m  
stopping pipeline {:id=\>"main"}  
The signal HUP is in use by the JVM and will not work correctly on this platform

D:\Tools\ELK\logstash-2.4.0\bin\>

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [September 15, 2016, 6:04am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/6 "2016-09-15T06:04:43Z")

</div>

Yes, but that's because you have a relative path in your file input configuration:

> <https://github.com/logstash-plugins/logstash-input-file/blob/v2.2.5/lib/logstash/inputs/file.rb#L187>

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [September 15, 2016, 6:12am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/7 "2016-09-15T06:12:46Z")

</div>

I've raised an issue to improve the error message.

> <https://github.com/logstash-plugins/logstash-input-file/issues/139>

---

<div class="post-metadata">

**Author:** ![Senz79](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/senz79/32/42874_2.png) [@Senz79](https://discuss.elastic.co/u/Senz79)\
**Post date:** [September 15, 2016, 6:14am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/8 "2016-09-15T06:14:05Z")

</div>

Thanks a lot for the support. The below link helped me to resolve the issue

> <https://github.com/elastic/logstash/issues/5821>

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [October 5, 2016, 1:17pm UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/9 "2016-10-05T13:17:27Z")

</div>

> [@](#):
>
> The signal HUP is in use by the JVM and will not work correctly on this platform.

This message is not fatal to Logstash. If you are having configuration errors, they are not what is generating these messages. The HUP message is actually from [JRuby](https://github.com/jruby/jruby/blob/915993886ae6663586d893b7d237f750068aceb5/core/src/main/ruby/jruby/kernel/signal.rb#L35).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:35am UTC](https://discuss.elastic.co/t/logstash-giving-hup-error/60559/10 "2017-07-06T04:35:38Z")

</div>


