# Logstash initialization failed

**URL:** <https://discuss.elastic.co/t/logstash-initialization-failed/381933>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [September 14, 2025, 4:52pm UTC](https://discuss.elastic.co/t/logstash-initialization-failed/381933 "2025-09-14T16:52:49Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![piyush\_hn](https://avatars.discourse-cdn.com/v4/letter/p/eada6e/32.png) [@piyush\_hn](https://discuss.elastic.co/u/piyush_hn)\
**Post date:** [September 14, 2025, 4:52pm UTC](https://discuss.elastic.co/t/logstash-initialization-failed/381933/1 "2025-09-14T16:52:50Z")

</div>

Anyone knows what the below error means please ?

> [2025-09-14T16:24:11,750][ERROR][logstash.outputs.elasticsearch][main] Failed to install template {:message=\>"Failed to load default template for Elasticsearch v9 with ECS v8; caused by: #\<LogStash::ConfigurationError: Failed to load template file '/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch/templates/ecs-v8/elasticsearch-9x.json': Template file '/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch/templates/ecs-v8/elasticsearch-9x.json' could not be found\>", :exception=\>LogStash::ConfigurationError, :backtrace=\>["/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch/template\_manager.rb:40:in `load_default_template'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch/template_manager.rb:27:in `install\_template'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch.rb:663:in `install_template'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch.rb:371:in `finish\_register'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch.rb:328:in `block in register'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/plugin_mixins/elasticsearch/common.rb:172:in `block in after\_successful\_connection'"]}  
> [2025-09-14T16:24:11,751][ERROR][logstash.outputs.elasticsearch][main] Failed to bootstrap. Pipeline "main" is going to shut down {:message=\>"Failed to load default template for Elasticsearch v9 with ECS v8; caused by: #\<LogStash::ConfigurationError: Failed to load template file '/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch/templates/ecs-v8/elasticsearch-9x.json': Template file '/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-elasticsearch-11.22.7-java/lib/logstash/outputs/elasticsearch/templates/ecs-v8/elasticsearch-9x.json' could not be found\>", :exception=\>LogStash::ConfigurationError}  
> [2025-09-14T16:24:17,426][ERROR][org.logstash.execution.ShutdownWatcherExt][main] The shutdown process appears to be stalled due to busy or blocked plugins. Check the logs for more information.

---

<div class="post-metadata">

**Author:** ![Musab\_Dogan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/musab_dogan/32/70691_2.png) [@Musab\_Dogan](https://discuss.elastic.co/u/Musab_Dogan)\
**Post date:** [September 16, 2025, 8:00am UTC](https://discuss.elastic.co/t/logstash-initialization-failed/381933/2 "2025-09-16T08:00:31Z")

</div>

Probably it’s because of version compatibility. Please check the Logstash and Elasticsearch versions. [Support Matrix | Elastic](https://www.elastic.co/support/matrix)

> Failed to load default template for Elasticsearch v9 with ECS v8

---

<div class="post-metadata">

**Author:** ![piyush\_hn](https://avatars.discourse-cdn.com/v4/letter/p/eada6e/32.png) [@piyush\_hn](https://discuss.elastic.co/u/piyush_hn)\
**Post date:** [September 17, 2025, 5:05am UTC](https://discuss.elastic.co/t/logstash-initialization-failed/381933/3 "2025-09-17T05:05:53Z")

</div>

That’s what I figured out.
